Yosemite compatibility

Running Yosemite 10.10.5
I purchased a new turntable that came with latest version of Audacity. Prior to the Yosemite and turntable upgrades, I had been very successfully using another usb turntable and Audacity to record LPs and save to iTunes. Before loading the new Audacity software, I dragged the earlier version to trash. After the new software load failed, I deleted all trace of it and dragged back the earlier version. All seemed to be working well until importing the file to iTunes. 1st; is the correct path /volume/itunes/library/ ? I have tried with this as the path and have tried using both the “file>export” and “export multiple” commands, but neither work as they did formerly.
Any help would be much appreciated.

I don’t think I’ve ever worried about the iTunes path. I Export WAV (Microsoft), 16-bit to the desktop. Then Control-Click (right-click if you have an appropriate mouse) > Open With > iTunes.


2.0.4 predates Yosemite, so strictly speaking, 2.0.4 would not be compatible with Yosemite. You might find problems.

The current version of Audacity is 2.1.2 from http://www.audacityteam.org/download/mac. 2.1.2 should launch OK. If it doesn’t, try deleting the file “audacity.cfg” in the folder ~/Library/Application Support/audacity/ . You can get there using Go > Go to Folder in Finder.

The correct path is Home/Music/iTunes/iTunes Media/Automatically Add to iTunes.


Thanks for all of the feedback, I’m back on track (so to speak).