wxWidgets Debug Alert (Audacity 2.3.2) W8 [Solved]

wxWidgets Debug Alert (Audacity 2.3.2) Windows 8

I did a system-restore on my Windows 8 machine, (normally not a problem),
but this time an error message appears when I try to launch Audacity …
vxWidgets Debug Alert (Audacity 2-3-2) W8.png
If I rename the Audacity folder in AppData/Roaming the problem is solved,
but I have to reinstall many plugins &, more importantly, lose their presets.

Is there any other way I can cure the vxWidgets problem and keep my plugins & their presets as is ?.

Audacity 2.3.3 “should” work on Windows 8, but:
Audacity 2.3.2 is very old and no longer supported.
Windows 8 went out of support on January 12, 2016.
(Windows 8.1 reaches end of support on January 10, 2023)

The current version of Audacity is 3.2.0. I don’t know if it runs on Windows 8 as it has not been tested with that operating system.

Audacity registers plug-ins in a file called “pluginsregistry.cfg” in the AppData/Roaming/Audacity folder.

It’s possible that an incompatible plug-in may be causing the problem, in which case restoring that file will may cause the problem to reappear. If the problem does not reappear, then restoring that file will restore any plug-ins that are installed on the system.

Plug-ins that are installed locally in Audacity (such as Nyquist plug-ins) may be in AppData/Roaming/Audacity/Plug-Ins
To reinstall those plug-ins (if any), copy them over from the old (renamed) folder to the new AppData/Roaming/Audacity/Plug-Ins folder.

2.3.2 (32-bit) & 3.2.0 alpha (64-bit) were working for me on Windows 8.
It’s just that the system-restore I performed has corrupted something.

Restoring either “pluginregistry.cfg” or “pluginsettings.cfg” gives vxWidgets error messages.

I have an archived copy of my computer on an external hard-drive,
I’ll try using the “AppData/Roaming/Audacity” folder from that.

Perhaps you could try a “portable” Audacity (create a “Portable Settings” folder in the same directory as audacity.exe https://alphamanual.audacityteam.org/man/Portable_Audacity), and see if that has the same problem when you put “pluginregistry.cfg” and “pluginsettings.cfg” into the Portable Settings folder.

Creating “Portable Settings” folder did not help: it just generated new error messages in addition to the wxWidgets ones.

Transplanting a month-old copy of “AppData/Roaming/Audacity” from my archive has solved the problem :slight_smile:
Audcaity 232 effects & presets restored..png
The moral of the story: always have a back-up.