Won't record to USB[SOLVED]

I am running Mac OSX version 10.5.8. I have downloaded Audacity 2.0.5 (.dmg). The download appears to be fine. I am able to see all the screens.

The problem is: When I try to select the recording device, I am given only two options: “built-in microphone” (which records external sounds), and “built-in input” (which records no sound). The USB cord is fully connected.

What am I doing wrong

Audacity does not automatically update its device list if you add a device after starting Audacity.

Please try restarting Audacity or try Transport > Rescan Audio Devices from the Audacity menu at the top of the screen.


Thank you Gale

I tried both your suggestions. Neither one worked. What is odd is that the manual says that the recording device selections should be “USB Audio Device” or “Microphone Array (USB)”. I only get the options for “built-in microphone” and “built-in input.” I’ve tried both. While “built-in microphone” does work, it’s recording external noise (i.e. my voice). When I select “built-in input” and record, the screen shows that the device is recording, but there is no audio response on the screen (even with the device volume and the software volume max’d out).

A friend suggested that Mac system software might be blocking the USB signal (it thinks it’s a copyright infringement) but that seems unlikely, otherwise, your product would not work on any Macs.

I would VERY much like this product to work. Is there anything else I can do to trouble-shoot this?

Close Audacity. Restart the Mac. Leave everything plugged in.

When the Mac starts:
Apple (upper left) > System Preferences > Hardware > Audio > Input.

Does your USB device appear in that list? If not, then it didn’t appear to the Mac and it doesn’t matter what you set in Audacity. The computer has to get the hardware first. If it did appear in that list, let us know.


Also try changing the USB cable if system preferences does not see the USB device.


Koz -

Thanks for the guidance. Still not working. Plus, “Apple > System Preferences > Hardware” does NOT have “Audio” as an option, so I guess it’s not seeing the device.

Another person suggested switching the USB cable, but this is a specialty cable that came with the device, and I don’t have a replacement. I’ve pretty much reached the end of my patience with this product.

Just sent an email saying I couldn’t find “USB” in the system preferences. Looked again (it was in a different place, called “Sound”). It says “USB PnP Audio Device”. So what does this mean?

OK. So after re-starting I found in system preferences > hardware > sound an option called “USB PnP Audio Device”. I selected this, and put the input and output volumes at 50%. When I run Audacity, I see this device in recording device input drop-down. When I try to record, I get an error message (“error while opening sound device. Please check the input device settings and the project sample rate.”) I don’t know what this means and have run out of options.

What exactly is this USB gizmo - make and model number?

You can use pretty much any USB cable for a USB turntable or cassette deck. A significant minority of the cables that come with USB turntables or cassette decks are dead or faulty (don’t carry the audio signal properly). Hence the suggestion.

Yes you should look in “Sound” in system preferences, however you get there.

“USB PnP Audio Device” is some USB audio device. Try disconnecting the device you are trying to use from the computer and see if “USB PnP Audio Device” disappears from “Sound”. If it does, and reappears when you reconnect it to the computer, you can say that the Mac sees your device.

“Error opening sound device” covers a multitude of problems. Connect the USB cable tightly and try Transport > Rescan Audio Devices in Audacity. If the error persists, try setting project rate bottom right of Audacity to 44100 Hz.

If your device is a USB microphone for singing into, you may have to set it up in Apple Audio MIDI Setup. Open Finder, choose Go > Utilities then open “Audio MIDI Setup”. Please see here for settings you should make: Missing features - Audacity Support .


Hi -

I’m not sure if you will see the entire string of correspondence, so I’m going to repeat them.

I am using Audacity 2.0.5 on a Mac OSX.

I have had great difficulty getting my Mac to “see” the device (Cassette2USB, model CSUSB-05). The problem is that Audacity shows inputs only as “built-in microphone” and “built-in input”, neither of which are the device. With help from this forum (“Koz”) I got it to work a week or so ago. It involved restarting the Mac (with the device plugged) in. I had previously tried “rescan audio devices” in the “transport” menu from Audacity, and that didn’t seem to work. When it worked, Audacity (and the Mac) did show an additional device (I’m pretty sure it was “USB PnP Audio Device”). I was able to record from the device and to play back through Audacity. YAY!

Now it’s back to where it was (Mac is not seeing the device). I have tried again (restarting Mac with the device plugged in, checking the inputs on the Mac system preferences, and telling Audacity to rescan audio devices). NO LUCK. Since it worked once using the above technique, I know it’s not the USB cable or the computer, and frankly I’m not sure why it’s not working.

I am so frustrated I want to quit, but I absolutely have to get this to work.

What am I doing wrong, if anything? :angry:

You can probably ignore Audacity for a while. Back up to the black apple upper left.

Apple > System Preferences > Hardware > Sound (sorry) > Input. See if the device appears there and you can get sound with the bouncing blue-ball sound meter. This should always be there and working while you have the device plugged in. If it vanishes from Audacity, come right back here and make sure it didn’t vanish here, too. If it vanishes both places it may be defective or you may have a bad cable.

USB cassette machines and turntables are delicate creatures and we have a lot of trouble with them on the forum. They were never intended to work forever and sometimes they die a little too soon.

I don’t remember if we covered this, but back in Audacity.

Audacity > Preferences > Devices > Recording. select your USB “thing” and select Stereo. [OK]
Audacity > Preferences > Quality > Sampling > 44100, 16-bit. [OK]

Try to record.


thanks Koz -

I have tried everything, to no avail. The device only sporadically appears as an input. At one point it appeared that jiggling the USB cord caused a response, but only for a fleeting moment. One time the device did appear as an input, and i was able to record one cassette. When I re-opened the program, the device was gone again, and re-starting the computer (and going through the Audacity re-scan function) has not worked (I’ve tried several times).

This device has only been used a total of 4 hours, so it’s not “dying early.” I can only imagine that the USB to device connection (either the cord or the device itself) is faulty. I guess I’ll have to pursue the manufacturer to send me another one.

Thanks again for all your help. I’m pretty sure it’s not Audacity that’s the problem.

By “dying early” I meant it was intended to die after you completed the last cassette. It was never intended to be a gift to your grandchildren.

If it’s possible, you should try a new USB cable before you start returning machines. If the cable came from them, then you can call and see how they want to handle it.

Certainly having the player pop up and then vanish is not very good. I keep sending you to the apple in the upper left because that is the first port of call when the music enters the Mac. If it doesn’t appear there, it doesn’t matter what happens any further.


Since I last posted, I was able to get this device working again. I’m almost certain it’s a bad connection at the cord-device interface, or maybe a bad cord. Jiggling the cord causes the device to disappear and reappear on the input screen. Anyway, I’m going to see if I can get another cord.

On another note, should I able to hear the music play as it is recording? Currently I don’t hear anything, only when I play it back from the burn file. Seems odd that you can’t hear it while it is recording.

Yes. There is absolutely provision to listen while you record.

Audacity > Preferences > Recording > [X] Software Playthrough (select) > [OK]
Don’t select anything else.

People trying to record a live voice or microphone might not want that running, but for you it’s perfect.


Koz - You are awesome! I can now listen while recording. Huge improvement. Thank you for all your assistance in helping me get up to speed. I love the software, although it’s got way more bells and whistles than I have time to figure out. But, the beauty of good software is that an entry-level person can still use it effectively and not get swamped.

it’s got way more bells and whistles than I have time to figure out.

And it’s a simple editor.


For anyone else reading this - http://manual.audacityteam.org/o/man/recording_with_usb_turntables.html in the Manual covers setup issues including turning software playthrough on.

I’m locking this topic now as you seem to have solved the connection problem - as so often, caused by a bad cable.