Won't let me select splitting files based on labels [SOLVED]

I just upgraded to Audacity 2.3.0 (on Windows 10). I have a project I created before my upgrade, and I’d like to export it as ten different files based on the labels (which I added pre-upgrade).

When I select File → Export → Export Multiple, under “Split files based on”, the “Labels” option is grayed out and can’t be selected. (“Tracks” is selected by default.)

Any idea why this might be?

Thanks for any help!

When you open the project, can you still see the labels in the label track?

Yep. Here’s a screenshot.

Does the problem occur only with this one project, or all projects?

Please post a screenshot of the Export Multiple dialog.

I hadn’t thought to check on another project, but I just checked (on a project predating the software upgrade) and it worked normally! So there’s something up with this specific project.

Here’s a screenshot of how it looks on the project where it DOESN’T work.

I was hoping to see the whole of the Export dialog, in the hope that there might be a clue as to why this might be happening.

How big is this faulty project?

Sorry, here’s a screenshot of the Export dialog box.

Looks like the project folder is 778 MB.

I don’t see any problems there.

Could you attach the .AUP file to your reply so I can see if anything stands out there.

Sure, here you go. (I ripped the audio from a cassette I own and the labels are where the songs begin; I’d like to export this so that each label/song is its own file. I’m also fairly new to using Audacity, so if you happen to notice anything else fishy, I’d love to hear about that too! Thanks!)
Columbia Tape.aup (123 KB)

Mystery solved :smiley:

See: Exporting multiple audio files - Audacity Manual

Split files based on:

Tracks: Export each audio track in your project to a separate file. File names are based on the track names. Any labels in the project are ignored.
Labels: Choose this option if your project contains labels as well as one or more audio tracks.

Only labels in the uppermost label track are used for export. > If more than one audio track is above the uppermost label track, the audio of all those tracks will be mixed into the exported files, unless you press the Mute button on some of the tracks to exclude them from the mix.
The label track must contain at least one point or region label, thus:

• Point labels mark the start of each section of audio you want to make into a separate file
• Region labels span each section of audio you want to make into a separate file.

In your project, the first label track is track 3, and it has no labels in it.

Thanks! I don’t know how those empty tracks got there, but I hadn’t noticed them. I feel pretty stupid. Thank you so much for the help!!!

I’m glad we got there in the end :wink:
I’ll close this topic as “solved”.