WMA does not import [SOLVED]

I’m using Audacity 2.1.1 on Windows 10.

I tried to edit a WMA file which I created some time ago on my XP computer (don’t know which version of Audacity) and I rec’d a notice that Audacity could not edit a WMA file due to copyright issues.

But my recollection is that on my XP machine, I could edit a WMA file.

Is my memory wrong? Or is this a new development? And is there any alternative, other than converting my WMA file back to a WAV file, editing that, and then saving it as a WMA file (which I think is how I created this WMA file originally).

WMA isn’t a file format. It’s a container, like .mov or .avi. It could contain wav, it could be compressed, and it could be copyright protected with DRM.

The error suggests that it is copyright protected, but it’s probably another error, if you made that WMA yourself. As to what error, I have no idea. ffmpeg bug? Win 10 bug?

If you made the file yourself it’s NOT copy protected, so you’ve got another error. I don’t know of ANY “home software” that can add copy protection.

I believe you’ll need to download and install the optional [u]FFmpeg Import/Export Library[/u] in order to open/import an WMA file. (And if you haven’t already done so, it’s a good idea to download and install the LAME MP3 encoder at the same time.)

Can you play the file in Windows Media Player (or with other software)?

If you can play the file, you can try converting the file to WAV with [u]TAudioConverter[/u].


Note that copyright is a LEGAL restriction. Copy protection (and DRM) is TECHNOLOGY that prevents or limits copying (or at least it attempts to prevent it). Here in the US it’s OK to copy copyrighted music for your own personal use, but it’s illegal to crack copy protection, even for personal use.

Almost all commercial music is copyrighted, but not copy-protected. Original iTunes downloads were copy protected, and some early WMA downloads were also copy protected. MP3s and CDs (like regular-old printed books) are copyrighted by not copy protected. Commercial DVDs and Blu-Rays are copy-protected (and copyrighted, of course).

Thanks to all who replied. When I got up this AM I realized the problem was probably that I hadn’t installed the ffmpeg library; I did so and solved my problems.