Windows issue with recording audio cassette

I am trying to record an audio cassette with 2.1.1. The resultant audio while clear through the headsets, is recorded as a disjointed stream of every second word missing (See attachment). I run Windows 8.1.
Any help would be appreciated.

Try the suggestions on [u]this page[/u].

Thanks DVDDoug.

I have tried the changes and their permutations but still no luck. I have added the readout here.

You may have to try everything in that FAQ, or investigate the extra suggestions given on Managing Computer Resources and Drivers.

Is it a USB cassette player? If so have you tried another USB cable? The USB audio recording feature could be faulty, especially if you only paid a few dollars for it. In that case you could use an appropriate cable to record from the headphones out of the player to line-in (blue) of the computer.

If you only have a mic port on the computer the recording may be mono or may distort, but it “may” be OK for speech if you turn the recording volume down.