Windows 8.1 recording with multiple user accounts

Hi all,

under Windows 7 I used happily the Audacity scheduled recording function to record a show that I love on a small local radio station that does not podcast emissions. I had just taken a FM radio and plugged the headphone output of the radio to the line-in input of the PC sound card with a cable 3.5mm male-male. But this was before …

Then all changed the day I switched to Windows 8.1 …

With the same assembly and the same settings my show was sometimes recorded, sometimes cut in the middle, and often not recorded at all.

I thought it was due to the sleep function of the PC.
I discovered that my PC had a hybrid sleep function that I did not have on my old PC, so I thought it came from there. So logically I switched it off.
Unfortunately nothing changed.

I finally found almost by chance that if another PC user logs on with another user account that prevented the recording to take place.
I tried in config panel → Sound → Recording → input line and activated / deactivated “give priority to applications exclusively” it did not change anything.

In device manager everything seems OK, no yellow exclamation mark.

I also typed run services.msc. I put “music services” “audio windows” into account local service because I found that some people applied this solution (but they had an “error 1079” message)

I also conected a microphone to identify the point where it cuts. Speaking to say what I was doing then listening to my self-recorded file I clearly saw that the recording becomes flat when I login to another user account and resumes when I click on my own user icon.

I think my problem is with Windows 8.1 but it can also come from my hardware or setup of audacity, though I tried everything on the option of the host (MME directsound or WASAPI) but stil no change…

I use Audacity 2.1.0
My PC is a HP envy 700-120ef

I’m searching for I do not find a solution I am desperate.

Can anyone help me?

Thank you in advance.

The instant you said, “…another PC user logs on with another user account ,” you divorced yourself from the majority of Windows users. Are you using Windows Server?


Where is the Audacity TEMP folder located in your own user account? Can it be shared with other user accounts?
Was Audacity installed for “All Users” or for a specific user?

@kozikowski I am using Windows 8.1 not Windows server.

@Robert2 Audacity was installed for all users

you gave me a great clue, I immediately searched for that audacity_temp folder and found it in

It was here C:\Users[my account]\AppData\Local\Temp\audacity_temp\ I tried from another user account and had no access to that folder.
So I moved it to another place where every user has access and full authorizations.

I tested again, but still the same problem :frowning: :frowning: :frowning:

Looks like when another user logs in, he takes exclusive control of the line-in input.

Then you must have a hacked Audacity because Audacity settings are always per user. You can get Audacity from us here:

If that other user actually uses Audacity you must not let them share the same temp folder as you otherwise they will step over your work and vice versa.

Does the problem happen when that other user uses Audacity, or even if they merely log on?

I have not tested in Windows 8.1 but I suppose it is conceivable on that OS that you may need to run Audacity with admin permissions.

We do know for a fact that on Windows 7 you can make simultaneous recordings to two instances of Audacity by running Audacity simultaneously from two user accounts.

If this is any anything to do with the location being written to, then you could save a project first before recording, and forbid the other user access to that folder.

Is this issue specific to timed recording, and something to do with the other user’s time zone? If so you could correct the user’s time zone or simply start recording when you are there and delete the recording that you don’t want.

Another question - is this a desktop that actually has line-in as well as mic in? If not, you are probably not getting as good a recording as you would by connecting to line-in on a USB interface.


What actually happens in Audacity? Does it record silence, or does it stop recording? Is any error shown?


I noticed now you said that the recording is silenced when the other user logs in. You might perhaps look at Event Viewer for some clues.

I tried this on Windows 8.1. I logged in as elevated admin, started a 10 minutes Timer Recording from the built-in mic, logged in as a standard user, and the Timer Recording continued and completed.

If being an elevated admin makes any difference, please see the explanation here: I disable “administrators in admin approval mode” which amounts to the same thing.


Thank you Gale for taking from your time to study my problem and answer.

So I am surprised that you managed to do a recording, I tried as you wrote, activated the admin account (net user administrator /active:yes) loggged in, manually launched a recording. (I did not try the scheduled recording)
Audacity records the radio connected to the line-in jack, but as soon as I leave the administrator account for another account (without closing administrator account of course) the recording goes on but it just records silence.
When I come back to the administrator account the recording has sound again.

I tried on a friend’s computer who runs windows 8 too (on an HP computer too).
It is exactly the same. Recording goes on but it is silenced while on another user account.

I checked the event logger too as you suggested.
Under log–>applications there is nothing here but winlogon ID 6000 when switching from an account to another. No error reported.

The strange thing is that if I go on the sound control panel–>recording device–>line in–>properties I check “listen to this device” I then can hear what is played on the line-in input through my headphone. If I then log in to another user account I will still hear it. This is true if I just switch to another user account or if I log off my account to log in another one.

I fear it is some win 8 security feature that prevents users to share the sound card. If it is so, it will be hard to bypass…

I have done the following test: playing sound from Audacity or a webpage (youtube) or a local media player on my desktop, then switching to another user account. The sound of the first user session is then muted.
I think this is a clue of what is happening: win 8 allows access to the audio card exclusively to the connected user.

I came across this post that is not very encouraging:

I read part of this post too that made me understand why MS implemented this feature in win8

So of course Audacity is not implicated in this “blank recording” issue :slight_smile: . This is all Windows 8 fault.
I don’t know how to get further… I miss my old win7 PC, I am thinking in getting rid of this win8 one and buying a second hand win7 one. Til now win 8 brought me just trouble.

Thanks for the links and research.

This article does appear to imply that the audio mixer still exists in the Desktop, though it’s clear that it doesn’t exist in the modern “touch” or “immersive” environment. There is good reason that it shouldn’t exist in that immersive environment.

There must be some reason why I did not encounter the problem in my test, but I have not yet tried playing audio in arbitrary apps then switching from the elevated administrator account to standard user account.

When you said:

you should know that those “Exclusive Mode” boxes have no effect when the Audio Host in Audacity’s Device Toolbar is set to MME. If setting the recording device to accept exclusive control has any relevance to this, you should use Windows DirectSound host. Otherwise, use MME host. I was using MME host. is also clear that some apps are allowed to play in the background if their stream is categorised as “BackgroundCapableMedia” or “Communications”. That categorisation appears to be something that the app programmer must set. However it is possible that if your recording device was set in Windows Sound as “Default Communications Device” that it might help. You can set that by right-clicking over the device in Windows Sound.

Other than that, launch Audacity from the Desktop if you are launching it from the immersive environment.


That being the case, you could try setting the Audacity recording device to stereo mix, or if you don’t have that, use the Windows WASAPI (loopback) choice:

If none of that helps, you could try installing the Windows 10 preview in a partition. I don’t know, but given the Desktop and immersive environment are more integrated in Windows 10, the behaviour may have changed. If it has changed then you’ll be able to get Windows 10 for free for a year after it’s released, as long as you have Windows 8.1 Update.