windows 7 doesn't seem to recognize audacity 2

I recently updated to audacity 2. I am using widows 7 home premium. I have used audacity for a few years and love it. The problem is that windows doesn’t seem to recognize the new audacity. No problems with beta version. I can open audacity and then open any music file. I cannot go to a music file and then open with audacity. I cannot even find audacity under the “other programs” option. I have browsed, found audacity and still not been able to use it in that manner.
The original installation of audacity 2 had “(86)” as part of its location. I redownloaded it and put it in c: programfiles. Still didn’t work. Thank you for any help you can give.

One of the limitations of Windows is that it can only recognise one program with a specified name so if you have two versions of the same program Windows will only recognise one of them. The problem gets worse if you manually make file associations due to how Windows (mis)handles file associations in the registry.
The best solution is to uninstall all versions of Audacity, clean out the Audacity file associations from the registry, then reinstall Audacity 2.

If you already use a registry cleaner, then you can use that (after uninstalling all versions of Audacity), otherwise there is a registry fix for Audacity here:

I uninstalled both locations of audacity and ran CCleaner. I tried to download that other registry fix but it kept opening with text (Notepad) programs and I could not see a way to remove the txt extension. I still think I got everything except I didn’t remove some dll(?) files as a message said they are used by the operating system. Little scared to do that. Still have same problem. Audacity does not show under"Other Programs" as optiong for opening a music file. When I browse I can find Audacity in (86) program files but it will not associate back to the files for opening music. All previous versions did including Beta.

Did you run the “Registry Cleaner” part of CCleaner? That should do the job. (to be ultra safe, make a backup of the registry when it prompts you to do so).

Uninstalled Audacity, ran registry cleaner of CCleaner, reinstalled audacity. I can only open any music files by first opening audacity and then opening file. NOW this seems to apply to all music players. When I try to double click on a song I get a screen that says Windows doesn’t recognize the file extension and I have to search the web for an appropriate program.

I can’t see your computer.

  1. Did you run the “Registry Cleaner” part of CCleaner?
  2. What sort of audio file are you trying to open? (right click on the file and select “properties” to see the file information).

I did run the registry cleaner. Had lots of .dll(?) extension files ( over 400 that were deleted).
I am trying to open .mp3 and .wav files. They will open if I open a media player (Windows or Audacity) first and then open file. I cannot open them if I just go to the song in Music and double click on the file.

So what happens if you select: “Select a program from a list of installed programs” and then click “OK”?

The most amazing thing just happened. I did everything exactly as I had been doing it, again. I right clicked on a song, chose the “open with” option. Went to other programs, browsed for Audacity. Selected Audacity and this time ( did the same sequence a couple of hours ago and it didn’t work) Audacity was added to the “other programs” list. Problem is now fixed. Computers have gremlins and we don’t know what they do, to paraphrase the actor in “I, Robot.”

:smiley: Glad it’s up and working again.

Thank you.