Windows 7 Audacity Internal PortAudio error / no devices

Yes, you can imagine I’m really frustrated at finding out everyone has this issue with Windows 10 and I’m the only one with it on Windows 7.

I was running Audacity 2.0.6, on Windows 7, the same Audacity that was working just weeks earlier which I used to record something with, when suddenly yesterday it comes up with the error “Error Initializing Audio”, “Could not find any audio devices. You will not be able to play or record audio. Error: Internal PortAudio error”.

Things I’ve done
• Updated to Audacity 2.1.2
• Uninstalled then reinstalled Audacity 2.1.2
• Checked all my Playback and Recording devices (they were still there, the same as when Audacity was working). Have a look and see if anything looks amiss yourselves: Playback, Recording
• Reinstalled my VIA HD Audio Driver twice (with restarts), going through 3 different versions. ( That is what its interface looks like now.)
• Tried to make sure there was no conflicting driver installed.

I recently installed a separate driver (this one to try and get Stereo Mix working (because as a separate issue it wasn’t detecting sound), and even though I uninstalled this driver a while ago, I’ve only opened Audacity for the first time again now after I first got the driver, so it looks like its installation was the culprit. However as far as I can see, it’s gone, gone from Add remove programs (here’s a look at that in order of most recent if it helps, gone from the Playback and Recording devices (it added 2 new ones which are gone). I can’t be sure about this, so maybe the guys here could help with that:

Device Manager: (as far as I know, those other drivers have always been there while Audacity worked)
My Audio Driver properties:

Are you running Windows 7 32 or 64 bits?
Have you got a standalone sound card, or is it chipset/motherboard integrated? Which make and model?
Here is from Windows 7 FAQ:

A lot of driver support for VIA chips is built into Microsoft Windows 7 (32 and 64-bit). If you’re looking for Windows 7 drivers, please check these FAQs first.


VIA only provides Windows 7 audio drivers for VIA Vinyl HD Audio Codecs and VIA Vinyl Audio Controllers that meet the Windows Logo Premium requirements, which can be found at the VIA Driver Download Portal. These are general sound effects drivers with common functions. System manufacturers and motherboard vendors customize audio hardware and software, so to ensure optimal sound quality and compatibility, we strongly recommend you obtain the system-validated and certified audio drivers directly from your system manufacturer or motherboard manufacturer, not from VIA.

*> Note> : If your VIA audio solution is not listed in the VIA Driver portal it does not meet the Windows Logo Premium requirements and therefore is supported by Microsoft’s in-box audio support. If your system uses one of these VIA audio solutions and you are having audio issues using Windows 7 (32 or 64-bit), it is recommended that you install a sound card which has Windows Logo Premium driver support under Windows 7.

Assuming this is as Robert2 asked a motherboard audio device, please give us the make and model number of your computer. Assuming you have a motherboard device, have you been to that computer manufacturer’s site and made sure you have the latest Windows 7 audio drivers for your computer model?

After that I would go to Device Manager. Right-click over each audio device except VIA HD and choose “Disable”. Restart Audacity and see if it can initialize the VIA HD devices. If so, enable the other devices in Device Manager until you find which of the others causes the failure.

By the way you don’t need stereo mix apps for recording computer playback. You can use Windows WASAPI loopback - see Tutorial - Recording Computer Playback on Windows.


Sorry for the late reply,

I’ll just give all the information I have:

it’s a custom built (by a business) computer.

I didn’t know it was from ASUS I should’ve been getting my audio drivers. I’ve just looked up the approved VIA drivers on the ASUS website this time, and will install them now. There’s also a BIOS update box that keeps coming up for the past couple of months which I never got round to doing, which I’ll also do, but this started well before my issue.

So I just restarted after installing the new ASUS drivers, and the problem is still there.

I’m almost 100% sure the problem was caused by the driver installation which messed something up, and I can’t seem to undo it. I searched for all residual files left using keywords in the program, but found nothing.

I tried disabling all and reenabling one by one my audio drivers in Device Manager, same error.

The only thing I did see change was that Audacity now had a startup guide window, and was not fullscreen but was windowed, which I’ve never had before.

Have a look at Remove & Uninstall Stereo Mix Plus 2.0 Completely from Windows

If it’s a custom built computer (not branded ASUS) then ASUS may not necessarily be the best source.

From your DXDiag information the audio device is Vendor Id: 0x1106 (VIA) and the Device ID is 0x0397. You can use this information to find the correct drivers on

Searching for vendor 1106 brings you to and there you can see that the Device ID 0x0397 drivers are Chip Number VT1708S at

That URL gives you a direct download of the correct drivers, irrespective if they help your specific issue or not. If the download doesn’t download properly, you should be able to find drivers for the VT1708S chipset on the Via site.


Perhaps that is because you reset the Audacity preferences?

If a residual part of Stereo Mix Plus is causing the problem then I would assume Audacity 2.0.3 from might initialise devices OK.


Also try