Windows 7 - Audacity 2.0.3 Not recording stream audio

I have followed instructions as per here:
And still not able to record streaming audio.

Recently uninstalled Win Vista, and now have Win 7 on this PC. All drivers are up to date, and “SOUND” settings (recording devices) have been set as instructed.

What else should I do?

Do you see a “stereo mix” or “What U Hear” choice in Windows Sound here ?

If not, have you tried everything in “HELP WITH RECORDING COMPUTER PLAYBACK OR STREAMING AUDIO” at ?

If you see stereo mix in Windows Sound and have chosen it in Audacity, what exactly is the problem - are you recording silence? Have you turned the input volume up?

Note that you cannot record streaming audio if you are using a USB headset - the audio has to be playing on the built-in sound device.

You cannot record streaming audio on Vista or later if the audio is turned down or muted.


It may be a long shot, but there is a situation not mentioned in the Audacity tutorials. If you have disabled ‘microphone’ in your computer bios setup, it may also disable the “Stereo Mix”, “Wave Out”, “Sum”, “What U Hear”, “Loopback” or similar function of your internal soundcard (called “Rec. Playback” in my HP mini5102 IDT software).

One reason you may have done this (and possibly forgotten) is if you normally use a usb line input / microphone device for recording from external devices to Audacity. The computer bios only controls the internal soundcard. So until you come to record streamed material (which is being handled by the internal soundcard) you will not have a problem. Microsoft and HP trouble shooters do not find this problem (bios is too low-level for them, and they will leave you thinking it is a hardware fault). It is tricky because streaming to the computer speakers is fine, and the “Rec. Playback” option is present in both windows microphone selection and in Audacity. Windows thinks “the device is working”, but the clue is it never shows any signal (green bars in Windows microphone setup, or red bars in Audacity microphone monitor), even though audio is streaming through your speakers. So when all else fails, check bios setup for a microphone device control, and make sure it is on if you want to record streamed audio.

You may need to reboot one extra time after re-enabling microphone in bios for everything to reconfigure: then those green and red bars should start jumping again and you can capture the streamed audio with Audacity. (May even be worth mentioning as a last resort check in the relevant Audacity tutorial).

Thanks for your suggestion. I can’t think I have personally ever seen any audio controls in a BIOS setup though I have heard of it on machines running Linux.

Was this mistakenly disabled in BIOS in your case, or did you do this yourself? Is “Microphone” the only audio input which could be configured, and you are saying it essentially disables all the audio inputs?


Hi Gale. Yes I had that exact problem which took me half of yesterday to solve, so I posted in case it helped anyone else. You are right that bios setup seems to offer different options in almost every model computer. In my HP mini5102, “microphone” is the only audio input offered to disable in bios (the machine has no separate line in jack); and yes it absolutely disables all 3 of (1) the inbuilt netbook microphone array; (2) the microphone in jack; and (3) the rec. playback function handled by the same IDT sound card. It does not affect microphone or line-in functions through a usb device.

I was surprised too (my excuse for taking half a day to find a solution); as mentioned the clue was no movement in the rec. playback volume bars despite audio streaming through the built-in netbook speakers. I recall turning off the ‘internal’ microphone in bios a long while ago as a fool-proof (?) way of ensuring no interference with recording via the usb device. Yesterday was the first time I ever tried to record a streamed sound - hence the troubleshooting.

Assuming it genuinely silences the microphone device, the best way on Windows Vista and later would probably be to right-click over the speaker icon by the system clock, then choose “Recording Devices”. Right-click over the device then choose “Disable”.


Agreed; software disable is the best approach in 99.9% of situations - it has the advantage of remaining visible to easily re-enable. However, it can also be reversed without warning by other software and it still consumes the (minimal) resources needed for the device and may leave in place any conflicts for those resources. Usually these are not problems. Turning a device off in bios (if the bios setup provides that option) avoids those issues - but it can be puzzling later unless one thinks to check bios settings as part of troubleshooting a problem. My input was just to mention that final simple check before people with the posted problem give up on finding a simple solution.