Windows 7 and the Echo Layla 24/96

Hi All,

I’ve been pulling my hair out on an issue I’m having. I’ve upgraded my PC to Windows 7 Pro 64-bit. I have an Echo Layla 24/96 with the 8.6 driver. In Audacity with version 2.0.5 I can only record in stereo (2 channels). The drop down menu shows “Digital In 1-8” but the drop down next to it only shows 1 or 2 channels to record.

I’ve tried different versions of the Layla driver and have even tried different versions of Audacity, get the same results.

Previously, I used this configuration with Windows Vista 32-bit and it worked perfectly, so the hardware hasn’t changed, just the OS.

What am I missing?


What do the Windows Control Panels say? Audacity is a complete slave to what Windows is doing. If Windows doesn’t supply a multi-channel show then Audacity is never going to see it.


I think Koz is suggesting that if you choose MME host in Audacity’s Device Toolbar ( ) then you should look in Windows “Sound” > Recording tab, right-click over Layla, choose “Properties” then on the “Advanced” tab, check that Windows Default Format is set to an appropriate number of channels. You can read for help using Windows “Sound”.

Another method would be to choose the “Windows DirectSound” host in Device Toolbar then in Windows Sound > Recording tab > Properties for Layla > Advanced, put a checkmark (tick) in both “Exclusive Mode” boxes.

Restart Audacity after changing Windows Sound.

If that does not help, please attach the contents of Help > Audio Device Info… in Audacity. Please see here for how to attach files: .

If you were able to compile Audacity with ASIO support ( ) it would probably solve the problem.


Hi Gale and Kos,

I appreciate your replies. I’ve been working with a buddy of mine that encountered the issue as well. He managed to make some more progress with it. He was able to get Audacity to record all 8 channels, but only when he downgraded to version 1.3! So, he mentioned the same thing that Gale did, he’s going to try to recompile Audacity with the ASIO support and hopefully it will resolve it.

Thanks again for the help! Audacity Rocks!

Before trying to compile Audacity, you could try the “Windows WDM-KS” host in 2.0.4 if you have not already done so ( ). Please note there is a small chance that Audacity version could crash or freeze your computer, hence why we are not currently releasing support for WDM-KS.

Yet another thing you could try: right-click over audacity.exe, choose Properties, then click the “Compatibility” tab. Try compatibility for earlier versions of Windows then restart Audacity.

I don’t know if your friend has the same or an older device, but there is always a chance that old devices using old drivers may eventually fail to work in a recent version of Audacity as the version of the PortAudio audio interface we use gets updated.