Windows 7 32-bit

Hi, I am new to this forum

My PC is running Windows 7, 32-bit version.
Have been using Audacity for a few months sporadically without any issue.
Yesterday I tried opening an MP3 file and got the error message:
“Audacity did not recognize the type of the file… Try installing FFmpeg.”
I tried multiple times to run the FFmpeg download using the "Preference/Libraries/
It’s creating a folder under C:\Program Files\FFmpeg For Audacity, with contains multiple files including “AVFORMAT-55.DLL”.
However, in the library, it still shows “FFmpeg library not found”.
I uninstalled Audacity, downloaded the 32-bit new version… getting same issue not able to open MP3 files.
Uninstalled 32-bit version, downloaded the 64-bit version… getting same issue not able to open MP3 files.
I now see it is running Audacity 3.1.2

I cannot upgrade my PC to 64-bit.
I need your help to get my Audacity to work again.
Is it possible to reinstall an older version running 32-bit, that does not require FFmpeg, like it was previously.

Any advice would be greatly appreciated.

https ://

Thanks very much.
I uninstalled 3.2.1 from Windows and installed 2.4.2
I can now open my older MP3 files.
However I still get this error message when trying to open new MP3 files I created using “YouTube to MP3 Converter”.
Is there a better or more efficient tool to extract MP3 song files from YouTube videos?

Do I need to configure Audacity so it does not try to do an autoupdate to newer version automatically? I would like to stay with version 2.4.2

Audacity 2.4.2 does not auto-update, so you don’t need to do anything to stay on 2.4.2.

When I was on Windows (I now use Linux) I used LameDropXPd, which is available (free) here: RareWares - LameDropXPd
(that is a reputable website despite it’s rather suspicious name).

Thanks a lot Steve.
I will try the software you mentioned.