Windows 11

Just bought new computer - LG “gram”, upgraded to Windows 11 Pro (from Windows 10 Pro) and installed Audacity 3.1.2. Can’t get it to work as it did in Windows 10 - that is, record directly from streaming computer input as opposed to recording through microphone. With MME showing, shows 2 input options: Microphone Array (Intel Smart) & Microsoft Sound Mapper.

I’ve tried all the options and work-arounds provided in Windows 10, but nothing seems to work. Can anyone help? Thanks

The “WASAPI loopback” method should work on Windows 11. See:

WASAPI didn’t work for my situation with my Shure MV7. I also didn’t understand the graphic showing the Audio Settings. It showed headphones as the input device. My mic wouldn’t work like that. Also, there is no loopback mode for the mic.

WASAPI only records the sounds which you can hear from the computer speakers, (no mic required).
To record a USB microphone you need to select that USB device, not WASAPI as the recording device.
To record the computer sounds & the USB mic at the same time you’ll need a virtual mixer.

I have the same problem. The choice of the audiosource RealTek, even available in the menu, does not give acces to recording while the microphone option does.
It seems that the issue is likely related to the compatibility of your computer sound hardware with Audacity source through Realtek . Mine, a ACER laptop, does not work properly.

I tried to upload and install the Realtek version recommended (either by Acer or by Realtek. It desinstalled the original one, install the fresh one and Audacity worked for a while, but past the next Windows 11 updating all the sound of the computer is crashed. Only issue: Microsoft on-line repair!
Audacity must solve the problem.
A fan of the application.


Check windows settings sound, or go to control panel sound. You will need Stereo Mix mixer enabled, it is disabled by default. Go to recording tab and see do you see stereo mix, if not click show hidden or disabled devices. also disable any windows sound enhancement eg Waves etc.
Then in Audacity set recording device to Stereo Mix. and set host to Windows Direct.

Windows updates can reset Realtek to defaults: which can enable “audio enhancements” you may have disabled, and disable “stereo mix” which you may have enabled.

Hey! Sorry to hear about the trouble with Audacity on Windows 11. Have you tried checking Audacity’s settings to ensure the correct input device is selected? Also, you might want to try reinstalling or updating your audio drivers. Good luck!