Windows 10 Unable to Record Streaming Audio with 2.2.2, Why?

Opening disclaimer: This is, admittedly, my first attempt at using Audacity with Windows 10. Prior to this, I’d been using Vista for the better part of the decade up until I was forced to change laptops last year. I’m just now getting back into using Audacity again.


So, I’m stuck in the position of I can’t get Audacity to record streaming audio and I have no idea why/what needs adjusting. Trying to look through the manual, the multiple different FAQs…honestly, I feel like I’m looking for the proverbial needle in the haystack here as to what’s wrong.

I go to check my available recording devices - as in, right-click my volume setting, click Recording devices, it’s the Recording tab on the window that pops up. Display Disabled/Disconnected Devices are both set to On. On that tab, shows just two Microphone devices. When even one of them is turned on, I can’t record anything meaningful, not even when the Audacity input device is set to Microsoft Sound Mapper - Input. I get a mostly-flat line with tiny dots along it, kind of like it wants to record external sound, not internal (playing) sound, but there’s no microphone plugged in to the jack.

When MME is my set Host, my only options are Microsoft Sound Mapper or any enabled Microphones. If I disable both Microphones in Windows, MME doesn’t let me choose an input device. Instead, I get “Error opening sound device”.

When Windows DirectSound is my set Host, it’s not much different. Input options are Primary Sound Capture Driver or enabled Microphones. No enabled Mics, no being able to choose an input device.

And choosing Windows WASAPI is more or less equivalent to spinning my wheels. Regardless of chosen input device, I click Record and the track opens and then it does nothing, like it’s not actually trying to record.

Changing my Playback device doesn’t change any of these.

Somewhere along the way, I read where it could be that my sound drivers need updating. I thought maybe that was a possibility, since my physical laptop is a Dell Inspiron 1525, which was released in 2008. I go to check the drivers - updated 2/21/2018. So the drivers being the issue doesn’t seem likely.

I’m evidently overlooking something but have no idea what. Can anyone help me narrow this down?

WASAPI is the way to go. In the device toolbar, the recording device needs to be set to the “loopback” option from the speakers. Note that when recording WASAPI loopback, if there is no active playback stream (from another application), there is nothing for Audacity to record so Audacity will just wait in record mode until there is a playback stream.

See the WASAPI section here:

So, I saw this:

You cannot play audio through an HDMI output or through a headset, headphones or speakers that connect via USB or wirelessly then record that playback using the stereo mix input of the built-in sound device.

And now I’m thinking that this might be why I was running into problems. Under my Vista Audacity days, most of the time when I recorded, I’d have headphones in, and it hadn’t been a problem. (Or maybe for all I know, it was because older versions of Audacity let me record with them plugged in? shrug) But I adjusted the settings to WASAPI like you said - at first, it still didn’t do anything. Then I took the headphones out and tried again - this time, it recorded, but after I stopped, put them back in and went for playback, it acted like it was playing as normal but I wasn’t actually hearing anything.

As far as dealing with headphones go, what’s the bottom line - is there a different configuration that I can use with them, or am I going to have to adjust to recording without having headphones plugged in?

Regular analog headphones should work the same as the speakers built-into your laptop because they both use the same soundcard & driver. USB headphones use a different driver and they will have different capabilities/limitations.

If you can’t get any of the “normal methods” working, go to [Recording Computer Playback on Windows]]( and scroll down near the bottom of the page where you’ll find some alternative software solutions. …These applications generally have their own special drivers or they have tricks for getting-around your driver limitations.

Yeah, I have regular headphones; I’ve never yet owned a pair of USB.

Uh…so you can disregard this question now, Steve - I seem to have stumbled into the solution I was looking for!

I went back into my devices, and under the Properties settings for my regular speakers, it turns out there’s an additional tab called “Spatial sound”. It’s not something I’ve dealt with before, but it goes like this:

Spatial sound format

Select the Spatial sound format you want to apply.

The drop-down menu gives me these choices:

-Windows Sonic for Headphones
-Dolby Atmos for Headphones

I chose Windows Sonic. Below the drop-down is an additional option, “Turn on 7.1 virtual surround sound”, that is checked by default and I’m leaving that on.

Anyways, I go back to Audacity with Windows Sonic for Headphones turned on, with the recording configuration set for Windows WASAPI like you told me to do, and…now it’s recording like the way I was used to doing before. :smiley:

…oh, and up until now I’d had my headphones plugged into the center jack. I have three jacks in front: Right is the microphone, center and left are headphones. Left lets me record with WASAPI, center does not.

So…thanks for pointing me in the right direction with the WASAPI settings. I should, hopefully, be good to go now. I wouldn’t have thought to do something with the Spatial sound setting, because it was originally turned off, and when I had my last laptop, I initially ran into a problem with the “Audio enhancements” setting - I had to turn those off because they were causing my recording to generate a “fishbowl” sound. Until trying the Spatial sound setting, my guess would’ve been that that would’ve caused a similar problem - not the case, apparently!