Windows 10 MP3 Length

I’ve been using the same method of editing podcasts for about two years now, but after upgrading to Windows 10 the other day, I’ve been running into a problem.

Every time I edit a file on Audacity and export it as an MP3, the length of the file doesn’t match up what the audio actually is. I first noticed this when importing it into Windows Movie Maker and seeing that no matter how long the image clip was, the audio would cut off. When I played that file in Windows Media Player, it showed as being 1:06:55 but would play until 1:07:03. This was under the Constant option, so I’ve tested it out in various different ways.

WMP = shows 1:06:55 but continues to play until 1:07:03
Winamp = plays perfectly fine
VLC = plays perfectly fine
Movie Maker = cuts off the last few seconds while in WMM program / video made from it cuts off about one second

WMP = shows 1:06:55 but stops at different times between 1:06:50 and 1:06:52
Winamp = shows 66:54 but stops at 66:44
VLC = plays perfectly
Movie Maker = adds several extra seconds while in WMM program / video made from it cuts off the last few seconds

WMP = shows 1:06:55 but stops at 1:06:53
Winamp = shows 66:54 but stops at 66:48
VLC = plays perfectly
Movie Maker = plays fine while in WMM program / video made from it cuts off about one second

  • WAV seems to have no problems whatsoever with all four programs, but I can’t just keep using that, as the files are over 300mb instead of between 30 and 60mb like with the MP3s. 10x the size would really get in the way of storage and the iTunes/Stitcher version uploads.

For good measure, I’ve gone ahead and tested out files that I’ve not edited in Audacity in any capacity and there aren’t any problems bringing them into any of the four programs, so the only thing that this seems to come back to is Audacity and Windows 10 not working well together, as I didn’t have this problem when I was using 8.1 and I ran into the issue with Windows 10 using both Audacity 2.0.6 and Audacity 2.1.1

Any tips or thoughts or anything of the sort, or am I screwed and will just have to find a different editing program that works better with Windows 10?

If you import it into Audacity, what is the duration (Select the track, then look in the Selection Toolbar with “Length” enabled).
If you made the MP3 from a WAV file, or from an Audacity recording, what was the length of the original WAV file / recording?

It plays what until 1:07:03? Is it adding 8 seconds of silence to the end?

Is that the same MP3? What is it doing, playing at double speed, playing only the first half, playing only the final half, skipping part?

I suspect that at least part of the “problem” has existed forever. MP3 files are never the “exact” length that they should be because of limitations of the format, though this should only be a fraction of a second, not 8 seconds.
Many players have problems determining the correct length of VBR files, so no surprises there.

When I import the different versions into Audacity, I get the same result for all of the MP3s, but a different one for WAV

Constant = 1:06:54.5239
Variable = 1:06:54.5239
Average = 1:06:54.5239
WAV = 1:06:54.490

The original audio clip was longer because I hadn’t edited it, but I also had saved over the original with the shortened and edited version, so I don’t have that for a direct comparison anymore.

For the 1:07:03, that’s how long it takes until the end of the audio (ie, at the end of the clip, I say “see you later” and it at 1:06:55 when it should be finished, I’m still not at that point, but I finish saying it at 1:07:03). It doesn’t add any silence on Windows Media Player.

Winamp isn’t playing at double speed, only playing half of it, or skipping anything (other than if noted otherwise for cutting off the end). I just didn’t translate the 66:54 into the 1:06:54 format, so that’s my fault in not making that clearer.

What strikes me as odd, though, is that I never had this problem for 2 years using the exact same tools and methods. I only noticed a problem after changing over to Windows 10.

Might you have contacted our feedback address recently about this? If so, we have been through this all before. If you import the Audacity-exported MP3’s back into Audacity they should be about 20 or 30 milliseconds longer than the source audio. If that is the case, that is correct for MP3 and Audacity has done its job.

Please, make sure you are using the recommended version of LAME for Audacity:

Please, contact Microsoft for support with Microsoft products, or use alternative editors, or use lossless audio formats for your videos. Storage is cheap these days.

Note that Windows 10 including Windows Media Player officially supports FLAC files, which are lossless and about half the size of WAV.

Note that Windows 10 does NOT officially support Movie Maker: You could try Avidemux.


MP3: 1:06:54.5239
WAV = 1:06:54.490
difference: 33.9 ms. That’s normal for MP3 (because the encoder / decoder delay is not defined by the MP3 format, so there is always a small amount of “padding” added).
The length of the WAV file is exact. “1:06:54.490” is the “correct” length of the audio. WAV is a fairly straightforward format (a kind of “PCM”) which is basically a series of samples at regular intervals (typically 44100 samples per second).
(Don’t know how you managed to measure the MP3 duration to 4 decimal places).

So Windows Media Player is playing the file a little too slowly.

and my fault for skim reading :blush: :wink:
So in fact WinAmp is cutting off about 10 seconds from the end of the VBR MP3? I’ve not used WinAmp for many years, but I recall that this was a known problem for WinAmp with VBR. I don’t know if it ever got fixed. I think there is also a setting in WinAmp to skip silence at the start/end of the track.

One thing that has changed recently in Audacity is that the defauly MP3 format was always 128 kbps CBR (the default in the soon to be released Audacity 2.1.2 is “preset standard”, 170 - 210 kbps VBR). Good modern players “should” be able to play VBR correctly by now (the format has been the same standard for many years). If you were previously using the default MP3 settings in Audacity, and if WMP / Movie Maker played CBR correctly in Windows 8, then there would probably be no reason for you to notice issues with ABR/VBR. The main problem now seems to be that WMP/Movie Maker, on Windows 10, do not handle CBR MP3 correctly.

Re WMP, have you checked that “Play speed settings” is snapped to exactly 1.0x ?

Does Windows Movie Maker not compress the audio when you export your finished video?
It is definitely recommended that “production” should be done in a lossless format (such as WAV). Whether working with audio or video, the data should be kept as high quality as possible during the production process. “Lossy” encoding should be the final step after the production is complete (and always recommended to keep a high quality backup of important work).

For what it’s worth, I can confirm that on Windows 10, a 128 kbps CBR MP3 that is just over 1 hr 6 minutes 53 seconds long with noise mixed in starting at 1 hour 6 minutes 47 seconds does not play that noise until 1 hour 6 minutes 56 seconds is reached. It is the same in “Groove Music” which is the new “universal” app that replaces Windows Media Player.

Again I do not believe this is an Audacity bug. There is the same issue with a CBR MP3 written by dBPowerAmp, which also uses LAME to encode.

Foobar2000 plays that file correctly on Windows 10.

Possibly not if iKing1 is saving MPEG video. If iKing1 saves H.264 video then I guess Movie Maker would compress the audio to AAC, which would let you use WAV audio input.

Sadly Microsoft media products are not the best choice in their field (and Winamp development is stalled). You should probably move on to other products.


Thanks for clarifying the difference between WAV and MP3 lengths, Steve. As far as how I measured it to the 4 decimal places, I just kept zooming in lol.

Play speed on WMP is indeed 1.0 on the dot. I’ve gone ahead and tested some files in Groove Music and they’re playing odd as well. I’ve not tried using dBPowerAmp, but if both that program and Audacity use LAME, then I would definitely imagine that’s the culprit more so than Audacity itself since WAV doesn’t seem to be messing up and that’s the go-between. All files that I’m trying out that are either MP3s that weren’t edited in Audacity or non-MP3s all seem to be okay, so if it’s LAME that’s creating the issue and not working well with Windows 10, then that’s quite lame indeed.

Against that, Foobar2000 (and as you say, VLC) play the LAME-encoded files correctly.

If you can post a link to a CBR or other MP3 file that plays correctly in WMP on Windows 10, then we could perhaps examine it to see what the difference is that doesn’t confuse Microsoft products. But much better to change products, or report the bug to those responsible - Microsoft - and see if they are prepared to fix it.


MP3 files created with the recommended version of Lame for Audacity today are exactly the same as (identical to) files created by Lame in 2011. These files have been working on a wide range of software on Windows XP, Vista, 7, 8, Mac OS X and Linux for over 4 years. Then comes Windows 10 and suddenly there is a problem of files playing to fast (unseen on any other platform).
Windows 10 is the new kid on the block. Seems that he doesn’t like playing with others (nothing new there).

Seems more like he will play with other’s toys, but not Daddy’s own toys.