Windows 10 latency

I have used Audacity for years on WIndows XP, 7, and now 10.
I have not had latency problems in the past - until now.
On my new laptop with Windows 10 it is a problem and on my old laptop Windows 7 it has suddenly become a problem.
On the Windows 7 I have recorded about a 100 multi-track songs I have wrote and no latency problems…until now.
I have tried the formula for correcting latency in the manual several times on both systems and it did not correct the latency problem?
My Windows 10 laptop has the most current version of Audacity.
What really bugs me is I have had no problems on the WIndows 7 old laptop for years-why suddenly does latency become a problem???

Please describe exactly what you mean by “latency problems”.

Its a lag in the sound I make in the microphone or with a guitar and the sound I actually hear as I do it.
If I try to strum my guitar the sound in the earphone is delayed and it naturally throws off the strum pattern.
My new windows 10 laptop and my old windows 7 laptop both are doing this.
The older one I have used Audacity on for years and never had a delay.
I would expect the newer laptop to maybe have a latency problem-but not the older one because it worked for over many years in Audacity with no latency
On both I tried using the Audacity manuals latency test several times and each time it looks as though both tracks are in sync at the end-but still it has a small lag when I actually record?

What sort of microphone are you using and how is it connected to the computer?
Where are your headphones plugged in?

I have tried using 2 different mikes-one is a Shure mike that goes thru a 3.5 input port on the laptop the other mike is a USB mike that naturally goes into a USB port on the laptops.
The headphones are connected to the headphone jack. No matter the laptop it lags.
I have used the Shure mike setup on the old Windows 7 laptop for years.

The thing that I find surprising is that you didn’t have the delay problem on your other computer. Were you using different recording software?

The reason that the delay occurs is because there is no physical connection between the microphone input and the headphone output. The sound has to go into the computer, be converted to digital, work its way through software and buffers, get converted back to analog, then back out through the headphones - that journey takes time (typically around half a second).

One solution is to use an audio device that provides a direct (wired) connection from the input to the output - this is called “direct monitoring” or “zero latency monitoring”. It’s a feature on many (bit not all) USB sound cards, and most high-end sound cards. I’ve never come across this feature in standard computer sound cards.

Another solution is to use software that supports ASIO.
ASIO is an alternative to the standard Windows sound system, but unfortunately Audacity cannot ship with ASIO support due to licensing restrictions. ASIO provides much lower latency than standard Windows drivers, so although there is still a delay, it is usually short enough to not be noticeable.

The final option is to disable “playthrough” so that you only hear the other tracks through your headphones. I assume that you will still be able to hear your guitar acoustically. To turn off “playthrough” look in “Transport menu > Transport Option” and disable “Software Playthrough” (it is off by default).

Since you’re recording with a microphone, maybe take the headphones off of one ear so you can hear the live guitar with one ear and the backing track in the other. (You can turn off Software Playthrough so you don’t hear yourself delayed in the headphones.)

There is always SOME latency through the computer…

You can adjust [u]Buffer Length / Latency[/u], but there may be other buffers somewhere in Windows.

A smaller buffer reduces latency but you are more likely to get dropouts/glitches. The buffers are required because of multitasking, and your operating system is always multitasking even if you’re only running one application.

There are audio interfaces where the monitoring path doesn’t go through the computer. Or you can use USB mixer and plug your headphones into the mixer. IMO - A hardware solution is best.

Latency and buffers -
When you record, the audio flows into a buffer (like a long pipe or holding tank) at smooth even-rate. Then whenever the operating system gets-around to it, the buffer is read and the data is written to your hard drive in a quick burst. If something (an application, driver, or background process) “hogs” the system for too long you get buffer overflow and a glitch. It doesn’t have to be hogging a lot of total CPU time, it just has to hog it for a few milliseconds too long…

When you playback/monitor the playback buffer is written-to in a quick-burst and the data flows-out at a smooth-even pace. In this case the danger is buffer underflow if the buffer doesn’t get refilled in time.

There is a FREE online book called [u]Glitch Free[/u] about optimizing your computer for audio.

My older laptop with Windows 7 had no problem until recently. (Which I do not understand why now it suddenly, after 10 years, has become a problem)
The newer computer with WIndows 10 had a problem from the start.
I have worked on this for about a month on and off and everytime I do the latency test, set the offset on the preference page it still throws me off.
I thank you both for bothering to take the time to try and help.