Windows 10 April Update and Mic Problem (a different one)

First my apologies for (possibly) abusing this helpful forum. While this is an Audacity problem in the sense that Audacity is the only way that I use my (currently unusable) Blue Yeti Pro mic on Windows 10 on a Dell XPS laptop. I recognize that this is a Windows system issue but so far my interactions with the Blue folks are not encouraging. I am using 2.2.1, BTW.

All was fine WRT Audacity and my Yeti Pro until yesterday (after the April Win 10 update). It had been a few weeks so I cannot be for sure regarding a cause/effect.

Yesterday I fired up Audacity and did not see the Blue Yeti from the Audacity pulldown. I also did not see it in Windows Sound->Recording selection. I ended up doing a “Update Driver” from Device Manager and Windows found a driver and did an “Update”. What was surprising was the ‘new’ driver had a date of (IIRC) 2006 while the one that was replaced was definitely later than that (although I don’t recall the actual date). But it worked and I did the short recording job that I needed to do - I also sent a service request to the Blue folks.

This morning I uninstalled that old driver and reinstalled the new one off the Blue Yeti website. I have tried this a couple of times without success. At this point Device Manager is showing two different “Blue Devices”. See the attached image. Note that neither one is inside the Sound and Game Controller Tab which is where it should be (I think).

“Update Driver” yields nothing on either driver. The Blue Yeti Pro driver says that it is working OK. The Blue USB Audio 2 driver is not installed. Note that this is what my Device Manager looks like after I uninstall BOTH of these drivers and then reinstall the Blue Yeti Pro driver from the Blue Mic website. And I am reasonably sure that before all this happened I had a single driver that lived inside the Sounds and Video Controllers pulldown.

So I am highly confused by all of this and am hoping that others have encountered this problem and can share a solution.



ps. I told this to the Blue Support folks and their first response was that “This Microphone supports Windows 10 and I should try it on another Windows 10 computer”. I am not sure exactly what I would learn from this (if I had another computer to try).

I must say that this is irritating. I do NOT have a System Restore point that will actually restore (all of them fail somewhere during the process). And not only did they fail, they erased themselves in the process of trying to do a restore.

That is really disappointing.


Look under Universal Serial Bus Controllers in Device Manager. It might be helpful to start with the Yeti unplugged, then plug it in to see if “something new” pops-up. It may not say “Blue Yeti”, it may say something generic. If it doesn’t show-up there, you might have a bad USB cable, a bad USB port, or the Yeti may have failed.

If it (or something new) does show-up, try un-installing the driver. Then un-plug and re-plug in the mic and the driver (hopefully the right driver or a “working driver”) will re-install automatically.

Doug, thanks for the response. The two (why are there two of them?) drivers that you see with the arrows in the original post image “go away” and come back when the Yeti is unplugged/plugged.

When I delete them and just plug in a driverless Yeti, Windows installs yet a different driver (“Blue DFU”) which fails with a code 28. See between the =='s below

The drivers for this device are not installed. (Code 28)

There are no compatible drivers for this device.

To find a driver for this device, click Update Driver

“Update driver” does not find anything.

Deleting that driver and re-installing the driver from the Blue website puts me in exactly the place that I was in when I started this thread.

i am beginning to believe that this issue is unique to me and may not have a ‘findable by me’ solution. FWIW, I have reinstalled the Blue website driver probably a half dozen times by now (different ports, etc).

Regarding the “Universal Serial Bus Controllers”, there are a bunch of them and none of them seem to be something of interest here. Is there something that I should be looking for? Another pic attached below.

Thanks again.


ps. This is a Blue Yeti Pro - the Blue Yeti (not pro) is different from what I understand.

Regarding the “Universal Serial Bus Controllers”, there are a bunch of them and none of them seem to be something of interest here. Is there something that I should be looking for? Another pic attached below.

I’d agree, but do you know what “Mass Storage Device” and “Composite Device” are? Are those real? Do you have other USB devices plugged-in? Maybe one of those is actually the mic?

…You probably will need to find another computer you can try-out. This does seem like a driver problem, but maybe the microphone is bad or maybe there is something else screwy with your Windows configuration. Often the best way to pinpoint a problem is to swap stuff around, and it’s probably easier to get your hands on another computer than another Yeti.

You could pick-up another cheap USB mic, but that’s going to use the Windows-supplied drivers. If it doesn’t work that might tell you something but if the generic mic works that doesn’t help much. And, I assume the USB cable is good since Windows is seeing the mic when you plug it in.

The USB Mass Storage is probably my Garmin 800 Bike Computer. It gets plugged in and downloaded after every bike ride and it gets unplugged ‘when I remember’.

I do have one other option. I ‘regularly’ do a main drive complete backup (using Acronis). So I could (after making a fresh copy of all the data that might have recently changed) do a complete restore of my hard drive back to what it was on 4/10. Then restore the recently changed data and see what happens.

That is a bit of a pain so I will probably do a bit more research (like why in hell do I get two different drivers from the Blue Mic driver install) before I go that path.


Well, this is interesting. I can now reduce this to a repeatable sequence of events.

  1. Remove ALL Blue Mic related drivers. You MUST do this from the Properties → Driver → Uninstall Device path. This will give you an option to ‘Remove all Software’ which you must do or it will just get loaded again (and sometimes it will just get loaded again anyway).

  2. Restart your Computer

  3. Plug in your Blue Yeti Pro and (unfortunately) a MS Driver (with a 9/18/2018 date) that ‘supports’ this device will load. You cannot avoid this because you cannot install the Blue Mic driver without first plugging in your Yeti. At this point windows will recognize the Yeti and I am not sure what functionality related to the Blue Yeti Pro Control panel (or something else) might be lost here. But this works for me and I can at least record using the Yeti. At this point the MS driver is installed in Sound, Video, Game Controllers where I think belongs.

  4. Install the Blue Mic supplied Blue Yeti Driver and do the required restart. For me at this point the MS supplied driver is gone, there is still some other driver “Blue USB Audio 2.0” in “Other Devices” that has failed, and the Blue Yeti driver is in its own category and it thinks it is working properly. But at this point Windows no longer recognizes the Yeti mic. So it is back to step #1 if you want to use your Yeti.

This is different than where I was 2 days ago (I think) because I was not using the path described in #1 above to delete the driver so it would get automatically reloaded. But at least now I can use my Yeti and have no idea if there is something lost here or not because I am using some other recent driver from MS that is HIGHLY unlikely (IMHO) to have ever been tested against the Yeti.

But progress of sorts and I am really getting out of my depth here.


Hi Dave,

I’m not sure if this problem has been resolve for you, but I just went through a similar experience and I thought I share it here because this chain is the closest thing I googled after struggling and testing my setup for a couple of days, and I also hope by having a repeatable set of steps and very specific description, we can call more attention to the issue.

Basically I am able to duplicate your steps 1 through 3, and if I stop here without going through step 4, everything seems to work ok. In this state my controls panel looks like the attachment “cp1”

Here I would offer a tip that allows you to better look at the relationship between different devices. Within Device Manager, go View – Devices by connection. Then you will see the drivers like the attachment “cp2” (this is without changing anything)

In this view you can see that Blue DFU is bearing the yellow triangle but everything is working normally. Looking at the device manager you can see that the Microphone and Speakers devices are not relying on the DFU. This leads me to guess that the health of the DFU is not critical to the general functionality of the mic.

Hope this post helps anyone having similar issues.


You probably will need to find another computer you can try-out.

I’m with him. This is an enormous amount of fuss and head pounding for a microphone that’s supposed to be plug and play.

Does that sound like what you have?

I’d like a sentence such as: “I tried it on me mum’s PC and it started working.”


Hello Koz,

It has been a few evenings’ worth of swapping and testing for me, because I really like having a good quality microphone for meetings and recordings, and I don’t want my expensive kit to turn into paper weight just at the flip of a driver. Now I have to write down the steps somewhere because someday I might take the mic somewhere and use it on someone’s computer, and the same issue will happen again.

For context, I swapped my setup with a few different things, and they support the following:

  • Blue Yeti does not have this issue. This only happens on Yeti Pro + Windows 10 + new drivers from Blue web site
  • this is not limited to Dell laptops; my self-built home PC behaved exactly the same way, and another laptop that has the new drivers also has issues.

All of this points to some kind of sloppy code in the windows 10 driver for Yeti pro. And it can only be resolved by the manufacturer.



All of this points to some kind of sloppy code in the windows 10 driver for Yeti pro.

So that should show up in a Google search.