Win 8 Audacity 2.1.2 Problem with Export Audio

I have suddenly encountered a problem with Export Audio. If I export one track it is fine, but if I try to mix down two tracks into one mp3 export, it is very very slow - indicating 40+ hours for this to happen. A single track takes about 10 minutes.

How long are the tracks? I can export a stereo, three-minute song to normal MP3 and it takes about eight seconds.

Really old, slow machine? Running out of drivespace? Audacity has to create show-size duplicate UNDOs when you do production. Those shows get big in a hurry.

I have suddenly encountered a problem

If you’re starting to run out of space, that will drive the system nuts. If you’ve been doing production for a long time…


You’re right - it is an old machine, and I usually record 2 hour radio shows with a voice track over the top - hence the need to mix down two tracks. The two tracks for a 2 hour show usually take about 18 - 20 minutes to export. I have now cleared lots more space - but probably need to defrag to get the full benefit before I try again. I still have 85 Gb free space though on a 232 Gb drive - surely that’s enough ? Why would it work okay with one track but not two ?

Whenever you have to do effects like that, Audacity has to build UNDO. UNDO is a perfect copy of the old show, so effectively, you are now juggling a four hour show. Also remember, Audacity does everything internally at 32-bit floating format to help special effects quality, not normal 16. So the shows are a lot bigger internally than you think they are.

If you were right on the edge of having enough horsepower and space to do the two hour show, four hour may push it over the edge.

I knew how to defragment in Win7, I’m not sure how to do it in higher Windows versions. There are conditions where Windows will defrag itself, such as leave it running and awake at 04:00 hours like Unix/Linux machines. I’m making up those numbers, but I think that is the case. you don’t have to manually defrag like in earlier versions, but you have to meet the conditions.

Do a drive quality check while you’re in there.

Did blasting out more room help? Even if it doesn’t completely solve the problem, if the symptoms change, you know you’re in the right track.


I have deleted lots of files - so I now have plenty of space, and defragged my drive. Uninstalled and reinstalled Audacity and the LAME encoder, and still having the same problem. I can export one track perfectly fine, I just can’t mix two tracks down any more.

I have now found - not a solution, but a workaround. My second track only had some sound at the beginning, and this was the export that wanted to take 40+ hours. Now maybe Audacity thinks that the space following the sound fragment was infinite or something, because I have added some more sound at the end of the 2 hours on the second track, and my export is back to taking 10 minutes ! Weird.

Now I have managed to create a mp3 file - I find that there seems to be ‘extra space’ at the end. When I check properties it says length is 2:00:00 but when I play it on media player, there is another 4 minutes on the end which makes media player go berserk when I click on it on the flow bar… harumph.

Uninstalled and reinstalled Audacity

Reinstalling Audacity doesn’t reset Audacity. The Windows installer has a provision to reset Audacity and you should click that option.

Just for grins and giggles, does Audacity 2.1.0 do this?
(Select Version 2.1.0)

Also the possibility you have a damaged file. With the first work on the timeline, duplicate it (Edit > Duplicate) instead of adding a second file and see how that goes.


It’s a known bug, much as you describe. You can see the known bugs by looking at the 2.1.2 Release Notes (the bug is described here).

The bug is already fixed in our source code, so will be fixed in the next 2.1.3 release of Audacity.


Try choosing Constant Bit Rate when you export.