Will Rosetta Screw Up Audacity?

I’ve been going completely insane trying to get Audacity 2.0.6 to run properly on an iMac with 10.6.8 installed. It’s a 2.66 GHz Core 2 Duo.
I’ve been working on this for over a month. At first install Audacity ran fine. then I started getting the “already running” notice (when it wasn’t, not even in activity monitor"
Then after re-starting and screwing around it would work for a day or two. I tried different operating systems, using disc utility to do a clean install each and every time.
By the time I got a fresh system installed and installed again the few programs I must use, Audacity would go to heck o me again.

I finally returned that computer believing it had to be defective. A fresh refurbed identical unit was sent to me. I loaded up my programs and tested Audacity repeatedly before taking the
machine to work to use in my office. Audacity worked perfectly. I really tried to abuse it and get it to quit working right, but no matter what I did it worked fine.

Got to work today, realized I still needed a small RSS program that I’ve used probably for ten years. I downloaded it, and it told me I needed Rosetta installed for that program to work. So I installed
Rosetta and Audacity has gone back to being all funky and completely not useable. So, this is leading me to believe, after it worked fine before, that installing Rosetta to make an old PPC
program work, has caused some sort of conflict that is preventing Audacity to work properly.

Does this make any sense? Or am I just going crazy because this is making me crazy?

Tim in Bovey

Does “funky and completely not useable” mean that you are getting “already running” or are there other issues as well?

2.0.6 is a Universal Binary rather than an Intel only app, however I would not expect that installing Rosetta would hurt Audacity or that by default the Mac should be opening Audacity with Rosetta. If Audacity is running under Rosetta that will slow Audacity up.

If you right-click over Audacity.app then choose Get Info, can you see an option “Open using Rosetta” and is it enabled?

What happens to Audacity if you quit the RSS app but retain Rosetta, or if you uninstall Rosetta and reboot?


I will experiment more when I get to work this morning.

When I first set this computer up it worked perfectly, then I remembered I needed the little RSS program which told me I needed Rosetta to make it work, so I downloaded Rosetta. When I went back to use Audacity I would hit record and it wouldn’t start recording. I would force quite Audacity (double checking that it quit in activity monitor) and when I try to relaunch Audacity it tells me it’s already running. I think that after restarting the computer and NOT using the RSS program, Audacity will work OK, but I haven’t confirmed this yet. I will find out when I get to work today.

I’ve been chasing this trouble for over a month now and yesterday it was fine until I added the RSS program and Rosetta. Now, I’ve used this program for years with Audacity every day of my life for like the past 8 years or more, but then I was on older computers where I didn’t need Rosetta to run the RSS program. So, I’m kinda chasing it in circles. It seems to me that when I launch RssBuddy which starts Rosetta, is when Audacity goes bonkers. And it won’t work again until I restart the computer and use Audacity before I use the RSSBuddy. My daily workflow is to record two 30 minute radio segments in Audacity, put them together, edit a tad, save to mp3. Then launch RSSBuddy and create the RSS file that goes with that days program, then upload the finished mp3 and rss .xml file created by RSSBuddy to our server. Then I generally don’t use Audacity again that day and then the next morning, I’m restarting again and hoping it will work. So, now that I’m really trying to track this down, it appears that RSSBuddy/Rosetta is the trouble, but I’m not certain.

From what I’ve read Rosetta is only running when an old PPC program is running (in this case RSSBuddy) so it’s not an issue until I launch that program.

Actually removing Rosetta is apparently difficult and the mac forums say it’s never necessary as it doesn’t run unless a program needs it. So, if I can repeatedly demonstrate that this is what happens for sure, I’m going to have to find a more modern RSS creator!

Tim in Bovey