Why is my microphone only recording audio properly in one channel?

Some details:

  • I’m using Arch Linux and the system Audacity package (3.4.2)
  • I’m using the Rode Procaster, which is a dynamic microphone.
  • I’m using the Vocaster One as my interface.

When I record my microphone, it defaults to stereo, but the channels are different volumes, as you can see. I want both channels to be the same volume.

When I use my Mac, both channels are the same volume. So it must be something to do with Linux. I don’t know how to fix it, though.

Any pointers?

It just gets weirder.

I plugged it into another Mac, found that Voacster Hub needed to update the firmware in my microphone, and then brought up Audacity. It then recorded in Mono by default.

I plugged it into two other Linux computers, and now it’s recording in stereo at the same volume. Which is what I wanted.

…why is it recording in mono on the Mac and stereo on the Linux machines?

I don’t know your sound equipment, but I guess your microphone is only mono (why should a microphone for speech record stereo sound?).

it probably depends on the settings of the computer (or Audacity) whether it just doubles the mono channel, or records only in mono, or records in stereo where there is no stereo signal.

If your microphone is mono, you could make an adapter where you route your sound to both channels before it gets into a computer.

I’ll explain my primary use case for the microphone:

Voice calls. For Signal and Discord. When it only records on one channel, I’m too quiet to be heard despite almost peaking on one channel. Discord doesn’t show me the channels.

I’m using Audacity for testing purposes (and occasionally for other projects).

I would love to know exactly what settings affect this.

That being said, it’s doubling the mono channel now in Audacity, so it should work fine when I use it for a voice call…hopefully. I have to assume this was due to the firmware update.

That’s an unusual result. I don’t know why there’s anything in the non-existing channel.

A true-mono file (one channel) will play through both speakers. And it should be full-volume from both speakers. I’m a Windows guy, and on Windows you have to set both Windows and Audacity to mono. (1)

You can also Split Stereo to Mono and then click the ‘X’ to kill the silent or bad track.

Stereo normally requires separate left & right microphones. But a single voice or a single instrument is mono. (except for something “wide” like a drum kit or piano). You could have one person on the left and another on the right, etc.

To make it louder you can run the Amplify or Normalize effect after recording. If it’s still not loud enough or intense enough you can run the Limiter effect with make-up gain to bring-up the volume.

The signal from a dynamic mic is typically about 20dB weaker than a condenser mic. But fi you turn up the gain and the level indicators on your interface show red, you are clipping (overloading/distorting) and you’ve got plenty of gain. And you can always amplify later.

It looks like your interface came with some control software and some of those adjustments may also be useful (if it runs on Linux).

(1) There is a “weird thing” that happens when you record in mono with one onl;y mic (or one input) on a stereo interface. The signal is cut in half so both channels mixed together don’t go over 0dB. But it doesn’t “know” you’re not using both inputs.

That shouldn’t happen with a mono interface.

1 Like

This is part of the reason why I bought the Vocaster One, because it has 70dB worth of gain, which is enough even for a dynamic microphone without a booster.

My old interface, the Audient iD4, did not have enough gain for the dynamic microphone even at full volume (it could still stand to be a little louder). But it was enough for my condenser microphone, the Rode NT1-A. And this pair of microphone and interface had worked well for several years…but all of a sudden, both microphones started recording in only one channel on the interface.

I didn’t know what the issue was. I could only assume there was something wrong with the interface, because it showed both channels were getting the same volume of sound on the interface’s…interface, but on Audacity, only one channel was getting audio. My Blue Yeti, with its own interface, still managed to get both channels. So I assumed it was the interface, and bought a new one.

And then I had the exact same issue with the Vocaster One…well, until it fixed itself somehow.

It does not run on Linux, but Geoffrey Bennett develops drivers and GUI software for Focusrite interfaces, and Vocaster One support will hopefully make it into the 6.10 kernel (which will probably release sometime in May): GitHub - geoffreybennett/alsa-scarlett-gui: alsa-scarlett-gui is a Gtk4 GUI for the ALSA controls presented by the Linux kernel Focusrite Scarlett2 Mixer Driver

That is exactly what I’m looking for. So even the iMac result, where my microphone is detected as mono, should be perfectly fine. The only thing that’s not fine is when my microphone is detected as stereo but only plays on one channel. I have to assume Discord detects the microphone as stereo but only plays on one channel, which is why it was so quiet…at least until now, where it records properly on both channels by default.

As mac-christian suggests, there are probably some audio settings affecting this. And they probably have to do with pipewire/pulseaudio. And I don’t know enough about either to figure out how it decides stereo/mono.

In Audacity Do … “Tools … Reset Configuration” … and start again…
Also in Audio Setup make sure you have Recording Channels set to " 2 "
also do … " Rescan Audio Devices " … that will let Audacity pickup what devices you have connected.

Also… this is a highly technical test … Do you have a simple 3.5mm audio lead that will plug into your PC… plug it in and start recording… You should get nothing except whatever “noise” is being picked up by the lead. … Then touch the ring and tip separately of the lead with your finger… and see do you get same response from both left and right channel… Then touch ring and tip separately with metal object (screwdriver) and see do you get same response from each channel.

One other thing … your PC may be headset socket input needing TRRS plug ( normally for a mic with a mute button) or maybe Mic or linein needing TRS… how many rings does your plug have…

TRS … is Tip, Ring, Shield.
TRRS … is Tip, Ring, Ring, Shield