Why Does Hard Limiter Mute My Audio?

I’m using Audacity 2.1.0, and as the topic title said I am having a bit of trouble. First let me tell you that I use Audacity for the purpose of making my recorded videos sound better. My routine is as follows whenever I record a video:

Noise Reduction. Normalize. Compressor. Equalization Bass & Treble. Normalize. Hard Limiter and finally Normalize one more time.

This usually helps my audio to hear not so loudly and be easier on the ears. However, I’ve began getting a problem. 2 actually, but I was able to fix the first 1 by unhooking my headphones before using Equalization. But Hard Limiter, now, would either completely silence the entire recording or glitch it out entirely like this.
Audacity Pic.png
Hard Limiter’s DB limit is set at -4, the other 2 are kept at defaults.

I should also tell you guys I have this problem on 2 separate laptops, both Windows 7, so before I even consider updating to the newest Audacity I wanted to be certain on how I could fix this in case I ran into it with the latest version of Audacity.

Does anyone know how to possibly fix this or why it started to happen out of the blue? Thank you kindly in advance. ^^

IIRC Limiter in Audcaity 2.x.x is a Nyquist plugin.
Nyquist plugins can only process a certain amount of audio in one go, (~1 hour ?).
Try applying the limiter on shorter sections.

[ BTW Limiter is now built-in to Audacity effects ].

You use Hard Limiter because it sounds better?

Hard Limiter is one of the effects used to simulate 2-way or taxi-cab radio distortion. Not good quality theatrical production. Was this process a recommendation from someone; are you following a posted formula?

my recorded videos

Are they posted somewhere?


It was recommended. I should had been more detailed and said all of my recordings are just my own voice, as you can see in this video of mine. And yes I have a little speech problem where I tend to talk a bit too fast. ^^;

This is what I try to do edit wise.

I try to keep every video at least around 30 mins. My ‘equipment’ if you want to call it, is just a Logitech webcam 110, as I can’t really afford anything better at the current time. It does the job well as both a camera, and at times, an audio only mic.

Also. Upon opening up Audacity to edit my audio, it mentions ‘orphan files that might belong to another project’, could that be related to my problem?

I don’t understand why that’s happening but somehow you’re getting a [u]Noise Gate[/u] effect.

A noise gate kills (or reduces) the audio when the volume falls below the threshold.

…O, maybe it’s not the limiter. Maybe you’ve mis-adjusted the Noise Reduction effect?

And how should I go about fixing that if it’s the reason? It’s the first thing I do, and I never change the default settings.

I’m guessing that you are referring to the LADSPA “Hard Limiter” plug-in.
I would highly recommend NOT using those ancient LADSPA plug-ins. Virtually all of them have bee superseded by better effects. In the case of “limiting”, Audacity now ships with “Limiter” (Limiter - Audacity Manual). I would highly recommend using Audacity’s Limiter effect rather than the old “Hard Limiter” LADSPA plug-in.

I upgraded to the most recent version of Audacity and this ‘Limiter’ seems to work. At least for the time being.