Why can’t audacity record all four of my microphones

I have a behringer u-phoria umc404hd this interface has 4 inputs and when i use 3 microphones on my interface with audacity it works but if i use 4 it freezes and won’t work at all this is for my podcast on my macbook air and it is on big sur 11.5.2. Thanks for all the help in advance

Has it ever worked with four?

Will it record four if you don’t plug the microphone in—three sounds and one blank track?

You may have exceeded the number of real-time sound tracks the machine can do in real time. Restart the Air and make sure nothing else starts. I used to regularly get one of the managers out of trouble at work by closing some of the thirty or forty things they had running at the same time.


Are you running the driver software that came with the Behringer? Recordings over two (stereo) are hard. Those aren’t natural and almost always take special settings or software.


What are the microphones? If they’re all four types that take 48v phantom power, you have have overloaded the USB connection.

Try recording the fourth microphone instead of one of the original three. Does that work? That should help clear the health of the fourth micophone.


You would not be the only one. See also: Audacity 3.0.4 Freezes During Capture From Audio Interface
and: Error on playback or recording

Yea i believe it’s because i exceeded what the number of real time sound tracks it can do and yes it will work on four tracks with blank tracks it’s just if all four a filled it will not work

Yea i believe it’s because i have overloaded the usb connection is there a fix to that?

on Mac Os there is no driver for it they say you can just use usb connection which works up to three channels cause on the fourth it stops working

I’m having a similar problem and I think this may fix / workaround the issue. Try disabling Software Playthrough of input to see if that helps. It seems to be working for me but I need to do more testing over the weekend.
Screen Shot 2021-09-24 at 2.12.51 PM.png

That should normally be disabled (off). (It is off by default).

Understood. The issue is that I would like to monitor Audacity through headphones and Software Playthrough of input looks like the only way to do this but it locks up the application. Would this be considered a bug as it only occurs when recording with 4 channels. 1, 2 and 3 channel Software Playthough works fine.

To monitor “Audacity”, enable “Play other tracks while recording (overdub)”.

If you mean that you want to monitor your microphone input, you do that from the umc404hd (headphones plugged into the umc404hd).