Where us FFMPEG, if it is there at all?

Howdy Gang. Long time user, first question. Kindly post a URL to a solution, as I’m sure this has been answered.
I am:
macOS Sierra Version 10.12.6
Audacity 2.3.3
ffmpeg_64bit_osx, just installed and restarted, at least twice. However, when trying to drag a youtube file into audacity repeatedly gives the error that it needs the FFmpeg library. I tried to use Terminal (‘which ffmpeg’) but it drew a blank. It also drew a blank when I asked ‘which quicktime’, so I must not be in the right folder (I’m in the Home folder). I also tried ‘mdfind ffmpeg’, but the list doesn’t show a relevant library.

Q1: How to find where the installer of ffmpeg_64bit_osx.pkg has installed the ffmpeg, if it is there at all?
Q2: How to teach Audacity where the package is located? In the current version, it doesn’t ask.
Q3: Does the 32-bit package have to be there for the 64-bit package to work?

No. You need the 64-bit version of FFmpeg for Audacity 2.3.3 on macOS.

If Audacity is running, quit Audacity and then restart it. Look in “Help menu > Diagnostics > show log”
Post the contents of the log in your reply.

OK, so it looks like it can’ t find the preferred placement so it went elsewhere:

Also, I had to save it & re-open in TextEdit first. When I selected all and cmd-c in the Show Log window, the window closed without copying. Is this normal?

20:29:05: Audacity 2.3.3
20:29:05: Trying to load FFmpeg libraries…
20:29:05: Trying to load FFmpeg libraries from default path, ‘/Library/Application Support/audacity/libs/ffmpeg.55.64bit.dylib’.
20:29:05: Checking for monolithic avformat from ‘/Library/Application Support/audacity/libs/ffmpeg.55.64bit.dylib’.
20:29:06: avformat not monolithic
20:29:06: Loading avutil from ‘/Library/Application Support/audacity/libs/ffmpeg_utils.52.64bit.dylib’.
20:29:06: Loading avcodec from ‘/Library/Application Support/audacity/libs/ffmpeg_codecs.55.64bit.dylib’.
20:29:06: Loading avformat from ‘/Library/Application Support/audacity/libs/ffmpeg.55.64bit.dylib’.
20:29:06: Actual avutil path /Library/Application Support/audacity/libs/ffmpeg_utils.52.64bit.dylib
20:29:06: Actual avcodec path /Library/Application Support/audacity/libs/ffmpeg_codecs.55.64bit.dylib
20:29:06: Actual avformat path /Library/Application Support/audacity/libs/ffmpeg.55.64bit.dylib
20:29:06: Importing symbols…
20:29:06: All symbols loaded successfully. Initializing the library.
20:29:06: Retrieving FFmpeg library version numbers:
20:29:06: AVCodec version 0x373466 - 55.52.102 (built against 0x373466 - 55.52.102)
20:29:06: AVFormat version 0x372164 - 55.33.100 (built against 0x372164 - 55.33.100)
20:29:06: AVUtil version 0x344264 - 52.66.100 (built against 0x344264 - 52.66.100)
20:29:06: FFmpeg libraries loaded successfully.

It would have been OK to just attach the file to your post (https://forum.audacityteam.org/t/how-to-attach-files-to-forum-posts/24026/1)
Copying the text directly is platform dependent. On Linux the text can be copied directly, but it becomes quite awkward to do so when there’s a lot of text in the window, which is probably why the developers didn’t add platform specific code to make copying available on all platforms (plus the fact that it is mostly only developers that use the log window). In short, yes I think that is “normal”.

This is the important line:

20:29:06: FFmpeg libraries loaded successfully.

That means exactly what it says. All is good, FFmpeg has been found and successfully loaded.