What is causing these vibrations?


I recently appear to have been getting this issue (As seen in the attachment below), I’m not exactly sure what is causing this & it appears to happen at random intervals but i can’t quite pinpoint the issue, just to be clear I know it is not the device I am using to record as i got it brand new out of the box this morning. The weirdest thing about this issue is it sounds no different to any of the other noise in the clip although because I use noise removal it mostly severely deteriorates the audio quality of the track.

The version of Windows I’m using is 8.1 & Audacity version is 2.0.6 (Tried with 2.1.1 but unfortunately the problem persists).

Thank you for taking the time to read this.

Audacity only records the signal and noise it receives. What exactly are you trying to record, using what equipment (makes and model numbers, please)?

What does your screenshot represent? Is it noise between words or songs, and is that before or after noise removal? And is the peak in the screenshot some unwanted random noise like a click? If so, how often do those random noises occur?

Can you post an audio sample that we can hear? See How to post an audio sample.

If there are random clicks in what you are recording, check your cables are tight both ends and try increasing Audio to buffer at Edit > Preferences… (Recording section). Try turning other applications off. Disconnect the internet, turn the WiFi off then turn your anti-virus off.


I’m trying to record commentary, the equipment i’m using is the Sony ECM-CS3 Condenser Mic.

The screenshot was supposed to represent the random waveforms that occur at the very start of the clip & about 5 or so seconds into the clip with nothing to make them occur although I realise now that a screenshot does not clearly illustrate that.

I have 2 audio samples, one before applying noise removal & one after applying noise removal, both clips have been normalised.



I am not sure what your complaint is from reading, but from listening, the problem seems to be that some click sounds in “before” now have an audible whooshing noise in them “after.” Is that it?

Please be specific about the slider settings you tried for Noise Removal and for new Noise Reduction.

My guess from looking at the spectrograms is that for 2.0.6 your attack and decay settings are too long. But 2.1.1 has no such settings, so I don’t understand what your complaint is there.

Some experience has shown that in 2.1.0 and later Noise Reduction, the default setting of 0 for frequency smoothing gives unsatisfactory results for voice, especially where there are breaths, but it’s better turned to 3 or more.

Clearly that is a concern here, and in this case I did not find that increasing frequency smoothing in 2.1.1 helped unless it was so high that it affected the voice.

Noise Removal is only meant for steady noise. It is not really designed for random noises like the clicks that are exposed (and made more whooshy) by removing the noise.

The clicks are really too broad for Audacity’s Click Removal. You may be better to work on preventing the clicks and/or reducing the noise (see my suggestions about the clicks). Or simply select passages between paragraphs and reduce their volume with Effect > Amplify… so you only hear a little bit of steady noise.

Where are you connecting this mic - into the mic port of the computer? You could look in the mic port properties on the Recording tab of Windows Sound (right-click over the mic port) to see if you can reduce the gain or “boost” on the mic or to see if enabling any noise suppression offered there might help. But enhancements settings like noise suppression can make things worse by introducing fades.


I am confused, 2.0.6 noise removal made that bad effect. I do not hear it with 2.1.0 if I use settings 12 - 6 - 0 or 12 - 6 - 6.

I have found that in the case of vocal performances and audiobook production under Audacity 2.1.0 and 2.1.1, the noise reduction of the beast (6, 6, 6) works remarkably well and leaves few if any artifacts. If you need more serious reduction, the next two levels 12, 6, 6 and 18, 6, 6 may be needed, Past that you have to fix your microphone, computer or environment (or possibly all three).

The music people may need other settings, but for vocal performances, this is pretty much a gift from the angels.

One very common problem as in above posts is the definition of noise. Noise is any constant undesirable sound that doesn’t change over the course of the performance. Computer fan noise, air conditioning whine and microphone hum are “noise,” but vinyl record popping, metrobusses driving past, thunder, dogs barking, and babies crying are not.

So noise is not just “stuff I don’t like.”

Once you establish the profile or noise sample at the beginning of the performance, noise reduction will go charging down the performance (or whatever you selected) looking for that one, single, exact noise. It doesn’t speak English or know what a baby, dog, metrobus, or weather are. It’s pretty stupid that way.

It also super important that your selected profile have only noise in it and nothing else. If you get a little voice in the profile by accident, Noise Reduction will destroy the show.


I’ve tried all the above posts (Thank you for the help btw) but unfortunately they have all had little to no effect.

As weird as this may sound I think the underlying cause of the issue is due to vibration that the microphone is somehow picking up.

As an example I recorded a 10 second sample of “Total” silence which when listened to shows no audible disruption etc, however there is clearly something causing the waveforms to become so erratic.

So you are connecting the mic to the mic port of the computer?

I agree the waveforms of the noise are a little more jagged than might be expected but you only have two fairly quiet clicks embedded in the noise either side of 7 seconds - if this had been the noise you had before it should have caused less problem for Noise Reduction.

The noise profile should not include any embedded clicks. Try zooming in a little and select a noise area for the profile that looks flat and centered over the 0.0 line.

Do I presume you are wearing this mic? Is the cord rubbing against your clothes or something else?


Yes, the microphone is connected to my computers combination jack using a Y splitter adapter (Tried the same test without the adapter, same issue arises so it’s not the adapter).

Upon further investigation I have realised that the waveforms only seem to be that way if I’m recording directly from my computer, I did the same test recording but instead using my phone & imported the audio file to Audacity & the waveform was completely flat, not jagged & erratic as has been shown in previous posts.

I’m not sure whether I hear these clicks at 7 seconds, though that could just be my ears.

Yes I am wearing this microphone, it’s clipped to my shirt, the cord & everything however are not rubbing on anything.

It’s not unheard of to cure a lot of sound problems by not using a computer. It would seem that using an already available computer and an inexpensive microphone would be totally the way to go, but that also means computer and data connection problems get burned into the show, see: Curse of the Yeti, Frying Mosquitoes, Connection Hum, etc. Oh, and don’t use a laptop with a loud fan. The fan becomes a performer.

Don’t fall in love with cellphone recording. I have zero doubt that you can produce a good quality track like that, but I’m also pretty sure most of them insist on saving the work as MP3. MP3s are End Products. You can’t use them to reliably cut into a final show. MP3 compression artifacts and sound damage get worse as you edit. If you get finished editing and your voice sounds talking-into-a-wine-glass honky, that’s why.

I have a voice recorder coming that may shed more light on live capture problems. We’ll see.


Yeah, I don’t plan on using my phone as a way of recording audio due to the poor quality/low Hz it delivers, I mostly just used it as a test to see if it’s the microphone or not, thankfully it’s not, I may just have to test more & do more research to see what I come up with.

I just don’t know where to begin, I’ve been trying to fix this issue since I got the mic but unfortunately I just seem to be going around in circles.

I only heard them after Noise Reduction had reduced the steady noise.


Sony clearly recommend using this mic with a digital voice recorder rather than a computer. The recorders they recommend only record to MP3 but that should not be insuperable for a voice recording if you use 192 kbps and 44100 Hz, as long as you import the recording into Audacity and export as WAV (not MP3).

Perhaps another alternative would be to buy a USB interface to connect the mic to then connect the USB interface to the computer. Many of these USB interfaces may give you the “frying mosquito” noise Koz mentions but that is quieter, less jagged, less click-embedded noise than you have now.


Strangely enough, I may have somehow fixed the issue.

All I did was uninstall my audio driver & reinstalled it, rebooted & now the mic seems to work flawlessly without any jagged/erratic waveforms, hopefully this keeps up.

Either way thanks for all the help!

Maybe the issue is that you’re connecting a stereo pip powered mic to a mono mic input?

I am afraid I still do not understand from your posts, what exactly was the original complaint.

Do you complain about clicking sounds? Noise Removal or Reduction does not eliminate those.

Do you want better results from Noise Removal or (2.1.0 and later) Noise Reduction? Please tell me exactly what settings you are using.

From what I see in this latest picture, I would recommand a highpass filter at perhaps 60 Hz and 12 db/Octave or more, to remove low frequency vibrations.

Clicks can be seen, not just heard, if you use Spectrogram view. They appear as vertical streaks.

Indeed though those clicks are more like a soft beep. They are barely visible even after noise reduction (I think they are a little hump of blue).

I can hear the beeps before noise reduction if I use headphones. I don’t think Noise Reduction is making the beeps worse.


First of all sorry for the inactivity, i thought i had fixed said issue, apparently it was only temporary.

The problem was not the clicks as i believe those were actually caused by my mouse, the problem was the fact the waveform was going rather hectic considering there was nothing i thought to be causing it, turns out the waveform turned out that way due to low frequency vibrations & using a high pass filter as you suggested fixed the issue.

Thanks for all the help!