Waves Diamond Bundle not installing

I’ve just installed Audacity 3.2.4
I’m on PC - Windows 11 Home - 16Gb Ram 12th gen i7
I already had Waves Diamond Bundle installed.
I copied first individual dll plugin files from Waves, then the entire Waves folder into the Audacity Plugins folder.
The Plugin Manager in Audacity sees the dll plugin files and marks them Disabled in the list. When I click “Enable” and “OK”, I get an error message
“Effect or Command at c\Program Files\Audacity\Plugins\Waves\Plugins<name of the dll file> failed to register.
Could not load the library
Could not load the library”
This happens for individual plugin dll files and for the ones within the Waves folder. I tried taking the individual ones out - same issue and taking the Waves folder out - same issue.
I tried re-starting Audacity and Restarting the PC, same issue.
What can I do to install those plugins?
Thank you.

Like a lot of commercial plug-ins, Waves does not officially support Audacity so it may not work. :frowning: Technically, it’s up to the plug-in developer. There MAY be issues with copy protection and open source software but that’s just a guess.

[u]Waves Supported Hosts[/u]

Thanks @DVDdoug
On other threads, people are saying that it simply works for them so does anyone else have any ideas?

Can you name one, for example?