Waveform suddenly half the size it always was - vexing to edit!

Waveform suddenly half the size it always was. It now has become vexing to edit in Audacity because I have to zoom way in to see the detail I need.

What is going on? I am not aware that I “did anything” to make this change.

The waveform used to very helpfully take up most of the space in the track from top to bottom. Now it take up literally half the space. The play back is good, perfect, exactly the same–but the SIZE is literally 50% smaller than it used to be.

REPEAT: I do NOT need to amplify it.

I Googled this issue and see this same problem raised repeatedly–but no one ever seems to be able to diagnose it properly or fix it. I’m hoping so much someone can actually help.

It’s adding a LOT more time, error, and frustration to my editing.

Settings are:
Speaker (Realteck(R) Audio (loopback)
2 (Stereo) Recording Channels
Speaker (Realtek(R) Audio)


did you zoom out on the vertical scale perhaps? Right-clicking it and choosing “zoom reset” should fix that. See also: Vertical Zooming - Audacity Manual

Thanks so much @LWinterberg - not sure that’s quite it; however, zoom x2 makes it bigger, so a terrific workaround.

Hi – the waveform has gotten even SMALLER and I have not changed anything. The “fix” recommended - to change the display to x2 was a temporary workaround, but now that is not even enough because even at x2 it is displays at maybe (not quite) 1/2 the size of the track.

PLEASE: someone at Audacity has GOT to have a solution for this. So many people have posted in different places about this issue. I never had this problem before 2 updates ago.

I am going to have to start using a different product. The waveform is too SMALL to properly edit with one track, let alone multiple tracks.

gain sliders were recently incorporated in the meters.

sliders now in the meters-2

If you accidentally moved the recording slider the recorded waveform could get smaller.

Hi @Trebor - appreciate your note and suggestion!

A couple of responses:

(1) as others have mentioned, this problem is not in any way playback level; the playback volume or amplitude is exactly the same as before–it is literally only the waveform that has become exponentially smaller; first is was 1/2 the normal size, now it’s 1/2 of that smaller size–the playback is precisely the same–it is fine but the waveform is vexingly difficult to edit


(2) the sliders you referenced (thanks for the screenshot) are not exactly “gain”; they control volume–such that when they are slid up, the SOUND of the source being recorded (e.g., a show being broadcast from a radio station’s website–but it could be anything) is louder; these sliders, what is being called “recording level,” does not in any way appear to be connected to recording level–it’s volume–changes the VOLUME literally in parallel on the laptop’s VOLUME control/sound output. So, you move the laptop’s volume slider up, the sliders on Audacity’s “recording level” goes up the same amount–you move Audacity’s “recording level” up or down, the laptop’s volume controls go up and down.

It has no effect on recording levels or waveform size. You can have Audacity’s “recording level” at the lowest (0%) or highest (100%) level and what records is literally precisely the same. Just as, obviously, you can have the computer volume on Mute or at the highest volume—and of course that does not affect the recording levels.

Ironically…? or tellingly…? Adjusting the sliders on Audacity for “Playback Level” does not change anything–slid to top or bottom, nothing changes with playback. Seems something is awry. but I don’t know where.

Thanks for any other thoughts!

Perhaps you were previously using the logarithmic scale on the waveform display,
the waveform is then much bigger, but not louder …

look at the vertical scale, on the far left

Hi @Trebor - thank you but that is not at all it. Maybe I am not being clear. The funny thing is every time this comes up the person posting seems to have a hard time conveying to this forum what is going on.

I am not looking for an enormous hulking blob of a wave form. Simply a normal-sized waveform. The SOUND has not changed. The SIZE of the waveform has. And as mentioned, first it was 1/2 the normal size and suddenly this weekend it is 1/2 of that smaller size. Nothing in the sound of it has changed at all.

It is a display issue. Any other thoughts? Or can someone else please help?

Could it be my recording settings? I am on the radio every week and I set my laptop to record those times I am on-air. I have been doing this for 18 months. This problem just started with 2 Audacity updates ago.


half wave display

If you try Audacity’s free competitor OCENaudio,
and the problem persists, then Audacity is not to blame.

Thanks, @Trebor - unfortunately the “half-wave” you posted the screenshot of has nothing to do with this issue.

For 15 years my waveform has filled the virtually the entirety of the track, vertically. No longer.

Maybe Audacity isn’t “to blame” but many other people have reported this…phenomenon…whomever’s to “blame.” I just fetched an old laptop with a previous versions of Audacity.

I played the same content at the same time on my previous and current laptops simultaneously. In the screenshot you will see the audio clip at precisely the same spot with same output/playback volume/amplitude----but see difference in waveforms. Top is what waveforms looked like for 15 years–bottom is current display.

It’s not just a smaller version: the envelopes are slightly different …

envelopes are different

Your newer Windows computer, (running Audacity 3.3.3), could be applying a playback audio-enhancement which is responsible, e.g. “Loudness Equalization” …

playback audio enhancements in Windows
(such enhancements can be on by default).

If you are recording the output of the computer such enhancements are baked-in to the recording.

Here’s how to turn them off … Turn off or Disable Audio Enhancements in Windows 10 - YouTube

hi @Trebor - thanks again - appreciate your thoughts. Wish that were it, but enhancements long ago were set to off. that’s not the issue.

I guess I can revert Audacity to the early version that’s on my other machine, and see whether the larger waveforms return.

Other than that, any other thoughts?


There can can be two layers of audio enhancements:
The RealTek ones, and another layer, sometimes called MaxxAudio.

hi @Trebor - thanks for your thought. But I have done every kind of search and scan and looked under every rock on my computer and I do not have MaxxAudio nor any other type or source of enhancements.

Any other ideas? My this week’s recordings waveform is smaller than last week’s. I’m going to have to stop using Audacity if this can’t get figured out. I have a big project coming up with multiple tracks and there’s no way I can edit precisely with such tiny wave forms…

Thanks for any other suggestions of the waveforms.

That you’ve used some app (in the last week) which has taken “exclusive control” of audio, (e.g. Skype, or Zoom), and it wont let go …

RealTek playback enhancement and MaxxAudio are the only things on my Windows machine that can effect the the WASAPI “loopback” sound recording …

playback enhancement

Well…that’s not it, but thanks for your thoughts and suggestions. I guess it will remain a mystery to me and subsequent inquiries on this topic that will inevitably come through.

This topic was automatically closed after 30 days. New replies are no longer allowed.