Waveform silenced when stop recording [SOLVED]

I’ve been using Audacity for quite a while to record my saxophone and it’s been great.
Suddenly a fault has appeared such that when I stop the recording the sound effectively disappears and I end up with a file of silence. I can see while I’m playing the signal is there but when I press stop it all goes blank. This happens on all the mic options.
Any ideas ? I’ve tried uninstalling and re-installing Audacity to no effect. I can only think I’ve inadvertently changed a setting somewhere.

I have Audacity v 2.1.1 and am running Windows 7

Hoping you can help


Have you filled up your hard drive?
Start > My Computer > C:\

I’m not a Windows elf.

That’s a common problem on the video forums. Someone will post that they made no changes but the computer started acting funny and losing work.


No it’s not that. My C drive is nowhere near full. I also don’t get any error message when I stop recording

Have you installed any new “security” or “PC maintenance” type programs recently?

Did you read my reply to your e-mail to our feedback address?

Take a look at the “Directories” section of Audacity Preferences (Edit > Preferenes…). Make sure you have permission to write to the temp folder mentioned there.

Make sure the drive is not faulty (for example, suffering a loose cable).

As Steve suggested, make sure a security or cleanup application is not deleting files in the Audacity temp folder. Norton will often delete your Audacity recordings if your Audacity temp folder has “temp” in its name. Type in a temp folder location in Directories Preferences that does not contain “temp” in its name, or File > Save Project… before recording so as not to use the temp folder.


Hi Gale,

Yes I just replied to you and your suggestion solved the problem. I changed Directory Preferences to put Audacity_temp into a different folder and all is well again.
I have some new Maint software which i think was hacking at the Temp folder as you said. Many thanks for your help.