Waveform missing upon import

Hi, I’m using Audacity 2.0.(whatever was latest May/June 2012) on Windows Xp Home.
When i try now to import mp3 or wav files, either by using import in the file menu, by clicking and dragging or just ‘open’ Audacity appears to perform my request as normal, taking the appropriate amount of seconds or minutes, with NO error message, a new project is created as normal with the stero tracks within, all text data in tact but with only one thing missing, there is no waveform, just the horizontal line!
These files have been imported before and some of which are stereo mixes of multitrack projects (which i have kept for future editing if needed so aren’t lost) but it seems i can now only work on existing projects, I don’t want to mix my multitracks down to stereo permanently but make exported copies occasionally to listen on my car speakers and maybe compress/limit/eq etc stereo files, now I can never re import them back into Audacity. These files play fine on othe media players ie. wmp and vlc and my mobile phone, which suggests there is music therein?
Another problem is I used to be able to to copy and paste tracks of audio into new separate projects (to make sub-mixes or work on layered vocals alone for example) and now i have the same problem, all that pastes is a track with the track name and no waveform. It only seems i can ‘duplicate’ within the same project.
All of these things were possible up until yesterday, hopefully I’ve just accidentally clicked something I shouldn’t and theres an easy remedy, please help,

Thanks in advance.

Do a screen grab and post what it looks like when the import fails. Does it look more or less like this except the blue line is flat instead of wavy?


Do you have the same !.0, 0.0, -1.0 for each track that I have in the illustration?

It does not play, right? No bouncing green meters?

What happens if you’re in one of these failures and you Generate Tone or other sound? Does it arrive?

Posting Instructions:


How strange.
Try this file, does this show up and play? (it’s just a short “beep”)

Yes, try managing music that you didn’t make. Koz

Thanks for the prompt response, I’m not home currently and using a work computer and will give as much detail as soon as I can but from memory everything is exactly as it should be but its as though the whole project has had its audio silenced, exactly as the example but a flat blue line which plays nothing and doesnt make the meters bounce. As for generating tone or adding your beep Steve I’m not sure, I will try later and respond with the results.

It might be worth pointing out my laptop is eight years old and I cleared out some temporary files in the hope it would run quicker though I’m sure all Audacity’s functions have been ok since I did this and before this problem.

Thanks again

I will try and rip something from a cd, I did try with a rip I made a couple of weeks ago but again, just horizontal blue line and an other wise perfect import.

It’s worth a shot. You could have inadvertently forced Audacity to use very old and out of date or damaged preferences.

Try resetting them (scroll down).



Thanks for the advice, tried to generate tones import and and record new audo within one of these failed projects, and any audio created seems to vanish immediately. I pushed a jack in and out of the microphone socket to create clicks and a waveform appeared for about second and as quickly silenced itself and disappeared leaving the blue line, which suggests silenced audio.

I’ve tried resetting preferences using your link which made no difference unless I have to restart my laptop in which case it still may.

So if you import or record into a new project, then Audacity works correctly, but if you import or record into one particular old project, then the audio disappears? Is that correct?

If i import to a new project no it doesn’t work and if I now try and add to this new failed project it doesn’t work.

Recording new music real time to a new project I’ve not tried recently, I’ll let you know. In short I cannot make NEW waveforms from material old or new, I can only work with (and within the confines of) the Audacity projects I had created before this fault.

Try this experiment.

  1. So that we have a clean start - reboot your computer.
  2. Open Audacity (new empty project)
  3. File menu > Save the project to your Desktop. Call it “test” (without quotes).
  4. Import the WAV file that I posted.
    Does that work?

Open “Edit menu > Preferences > Directories”
What is the “Temporary File Location”?
Does that folder exist and do you have write permissions?
Is there an option to use RAM (cache)?

Open “Help menu > About Audacity”
What does it say for the full version name and number?

I wll try this later and update, thanks for all your help.

tried to generate tones import and and record new audo within one of these failed projects, and any audio created seems to vanish immediately.

I want to address this for a second. When you record something, the blue wave appear as you’re recording and then vanish when you press stop? How about pressing Pause instead of stop? When you generate tone, the blue waves appear for a split second and then vanish without you doing anything?

When was the last time you ran the exhaustive virus check? Not the one that runs in the background, I mean the one where you go and drink coffee for a couple of hours while it works.

Microsoft makes a very nice on-line virus checker.



Not necessarily when i press stop, It was just as an experiment pluggung a jack in the mic socket to creat a click while record was running and no sooner has it created a wave as it disappeared, almost simultaneously as I was recording, like someone was silencing the audio a split second behind. Simply put I cannot see or hear or create any brand new waveforms, be it via import or recording. The only new thing I can create is a new project, and silent tracks with the horizontal line.

All imports tried work on other software and equipment.

Thanks for listening

Of the lists of things we told you to do, which ones of them have you done?


From your description, the issue seems to be that Audacity cannot write to the temporary directory, which was one of Steve’s suggestions.

If you really quit Audacity, opened Documents and SettingsApplication DataAudacityaudacity.cfg then saved it with no content except


at the top, that should have fixed it; reboot is not needed.

Or just CTRL + P to open Preferences, choose “Directories” on the left, click “Choose…” and select a directory where you have permission to write.

If none of that works, press Help > Show Log…, Log > Save… then attach the log (use “Upload attachment” underneath where you post replies).


Hi I seem to have managed to fix the problem (for now). I tried the preference reset to no avail and couldn’t import the beep due to problems with my internet connection, did a system reset back to the time before I cleared out those files and it seemed to restore everything back to the way it was,

Thanks so much for your time and advice