WAV import of a ZOOM H5 file fails (PCM, 16bit, LE, 44.1k)

Hello Folks,

I’m trying trying to import audio files into audacity from a ZOOM H5 portable recording device. The audio format on the ZOOM is set to:


on Linux, “file” reports:

file 20150326.wav
20150326.wav: RIFF (little-endian) data, WAVE audio, Microsoft PCM, 16 bit, stereo 44100 Hz

After importing into Audacity, I see a screwy waveform, and when I try to play it I hear only pops and static. At that point audacity is hung, and must be killed.

“mplayer”, “aplay”, “paplay”, and “audacious” can play the file without any problems.

What could be the problem?

I’m using Fedora 21 (x86_64) and audacity v2.0.6. Let me know if I should provide a sample from the ZOOM device.


Copy the files to your hard drive first, then check that they play OK in another application (such as Banshee, or whatever your default audio player), then import the hard drive copies into Audacity.

um, very kind of you to answer, but did you read my post?

  1. I quoted the output of the “file” command on linux, which kind of implies that the H5 files were already on my “hard disk” (or at least that the files can be accessed on some filesystem).

  2. I wrote that “mplayer”, “aplay”, “paplay”, and “audacious” can handle the H5 files without problem. These are four example of linux audio-playback utilities that have no problem with the H5 files. Also kinda implies that I had already moved the files from the H5 to my Linux box.

You want banshee? ok, tested with banshee, also no problem.

Thanks for taking the time, though!


Yes I did, and nowhere did you say that the files had been copied to your hard drive.

Does that mean that your files have been copied to your hard drive or that the files have not been copied to your hard drive?
I presume from the fact that you qualified your answer that the files have not been copied to your hard drive, so I would suggest that you try the suggestion in my first post. Yes it can make a difference where Audacity is reading the files from, particularly with uncompressed file types such as WAV.

ok, time to get us on the same page…

the very first thing I did was to copy the H5 files to the linux system hard drive. This was the only way I accessed the files using any linux programs.

After I copied the files to my hard drive, I used the utilities mentioned in my original post to play them. All linux utilities are able to play the H5 files successfully.

Importing H5 files into audacity (from my local hard drive) leads to the problem mentioned in my original post.


Thanks, much clearer :wink:

Yes please.

you can find a sample here:



The header is a little unusual for a WAV file, but looks “valid” and works fine here (Debian Wheezy, Audacity 2.1.0).

if you copy this test file to the same location as your ZOOM file, does this have the same problem or does it work OK?

It (ZOOM…) plays on Mac 2.0.6.

Your sample also gave me trouble, so I tried running audacity from the command line, and noticed zillions of the following errors:

ALSA lib pcm.c:7843:(snd_pcm_recover) underrun occurred

Apparently my pulseaudio config had gotten wedged – but only (AFAICT) when playing a WAV file with audacity. I changed a few PA parameters and restarted PA, and now audacity can read the ZOOM file perfectly well and play it.

Thanks for your help, and sorry to have wasted your time.


No problem.

As a matter of interest (and possibly of use to others), what changes did you make to PA?

um, apparently nothing useful. I very hopefully copied /etc/pulse/daemon.conf to ~/.config/pulse/daemon.conf and added the following settings:

default-fragments = 5
default-fragment-size-msec = 2

but it did not solve my problem. I’ll post when/if I find the solution.

thanks again,

If you are playing back using PulseAudio, try launching Audacity from a Terminal window using:

env PULSE_LATENCY_MSEC=30 audacity

Experiment with the “30” number to find the optimum value.