Wasapi not working [SOLVED]

I’ve been using audacity for a long time and have always been able to record from my sound card. after update to 3.0 when I try to use WASAPI I get the message Unable to open sound device… and these are the details…


{
“timestamp”: 1645395559,
“event_id”: “f326041e3bbc2c4099c9a5592fdd8c9f”,
“platform”: “native”,
“release”: “audacity@3.1.3”,
“contexts”: {
“os”: {
“type”: “os”,
“name”: “Windows”,
“version”: “10.0.22000”
}
},
“exception”: {
“values”: [
{
“type”: “Error”,
“value”: “Error opening sound device.\nTry changing the audio host, playback device and the project sample rate.”,
“mechanism”: {
“type”: “runtime_error”,
“handled”: false
}
}
]
}
}


I’ve changed every sample rate, and matched them in windows and on audacity multiple times. I’ve unistalled and reinstalled, and rolled back all the drivers. nothing seems to work! Please help!!

If this is an external USB sound card, make sure it is turned on and connected before you start Audacity. Otherwise Tranport > Rescan Audio Devices.

It is not, it is the internal soundcard that came in the computer. Which is an HP Omen. I never had this problem until I upgraded to 3.0. One other thing that may have changed, I now have the computer running through a Sony receiver via HDMI. So the sound is output through the HDMI port. I don’t think that should effect anything considering my goal is to record internally anyway!

Also I’m using Audacity 3.1.3 and Windows 11

Hmm… Even now, I am trying to visualized this… :confused:

HDMI drivers have caused issues for other Audacity users in the past. In the upper right corner of the Forum, you can search for HDMI.

Perhaps someone else will want to comment.

I will see what I can find when I search that! Thank you for your time!

I figured it out! If anyone else runs into this issue, in the sound setting on Windows 11 on the playback device menu under advanced options, it was set at 5.1 for my surround sound. I have to change that to Sonic for headphones. Once I do that I can us WASAPI like normal. But I do not have surround sound. So I just have to switch back and forth when recording via loopback, and everything else. Thanks for your time! I hope this helps anyone else that may be running into this issue!

Thanks for posting back with a solution I never would have guessed! I have marked this thread as solved.

That’s very useful. I’ll lock this topic so that it doesn’t get buried.

I just had this problem, but I refuse to use Sonic audio distortion.
I have a creative AE-5 and up to date drivers in windows 11.
What immediately solved it for me was going to the Sound settings in Windows Control Panel, opening properties on the output speakers → Advanced, untick ‘Enable audio enhancements’.