WASAPI loopback recordings do not start [CLOSED]

I am using the latest version of Audacity, version 2.1.3. Also, I am running windows 10, 64 bit. I thought that I had my problems with Audacity solved. However, I am still having a problem. I have Recording set to “WASAPI”. I have “Recording Device” (under Edit–>Preferences–>Devices) set to “Speakers (Realtek High Definition Audio)” When I click on the “Record” button, the recording cursor does not appear and does not move across the screen. I do not get an error message. But if, after clicking on the “Record” button, I click on the “Stop” button, and then again on the “Record” button, then, the recording cursor appears and moves across the screen as it should. So, to summarize, in order to record, after launching the Audacity software, I must click on “Record”, then I must click on “Stop”, then I must click on “Record” again. Then Audacity will record. If I only click on record once, nothing happens. Could this be a bug in the software, or am I doing something wrong? This problem seems to have started with the latest update of Windows 10. Although I am not sure if that is related to the cause. I have uploaded an attachment. In this Jpeg, I only pushed the "Record button once. Notice that the “Record” button has been pushed, but there is no recording cursor moving across the screen. In order to start recording, as stated above, I would have to push “Stop” and then push “Record” again. Any help would be appreciated. Thanks.


What are you recording? We never got the goal in that question.


I was trying to record streaming internet audio. I’m trying to understand why what I was trying to record is important to solving this problem. I ask this because, no matter what I was trying to record, even if it were just dead silence, still (and please tell me if I am wrong), I don’t think that it should be necessary to click the “Record” button, then the “Stop” button, then the “Record” button again in order to initiate a recording. I’ve never had this problem in the past. In the past, just clicking the record button once would begin recording. I just can’t imagine what would cause this. I have uninstalled and reinstalled the Audacity software several times but the problem continues. I could be doing something wrong, and I am always willing to learn. If you have any suggestions, I appreciate and value your advice. Thanks, Carl.

I just can’t imagine what would cause this.

Audacity might freeze if you send it into record but the data service pauses, in your case, the internet connection comes and goes.

There are other failures.



Rather than start a new post can I add to zpntenergy’s earlier post please?
I have a very similar problem. (Windows 10 64 bit with Audacity 2.1.3).
Using WASAPI setting with Recording Device set to Realtek Digital Output (Realtek High Definition Audio)(loopback)
Playback Device set to Realtek Digital Output (Realtek High Definition Audio). and 2 Stereo Recording channels.
I do not have a moving recording cursor but unlike zpntenergy’s situation I am unable to stop and restart to initiate a recording.
I have tried every combination of settings using WASAPI, MME, Windows DirectSound and also Speaker settings for Recording and Playback but nothing can persuade Audacity to record.

Would really appreciate any thoughts on what to do to start recording. Thank you

If you want Audacity to record silence or noise after pressing Record in Audacity before you play the content you want to record, don’t use Windows WASAPI (loopback) in Windows 10 Creators Edition or above. With that edition, Audacity behaves as Windows intends. The recording stream will not start until there is an audible stream to record.

In your case, also make sure Transport > Sound Activated Recording is off (not checked or ticked).

You can’t record computer playback with random devices and random hosts. If you have stereo mix enabled in Windows Sound, try MME host in Audacity.


Many thanks Gale,
You were right about checking “Transport > Sound Activated Recording is off”
I de-activated it and all works well now… Much appreciate your help.