vst plugins display only gray box

Mac OS 10.13.6 running Audacity 2.4.2. Of all the free VST downloads I have tried, only Nova’s Slick EQ and Nova actually display the graphical interface. I’ve had no luck with Voxengo AnSpec, GVST’s GSnap, or Melda’s MAnalyzer and/or MAutoPitch, all of which enable, but only display a gray box. I’d be most grateful for suggestions! Thank you!

Mac users generally use AU plug-ins rather than VST.
I don’t know which VST effects work in Audacity on macOS as I’ve never used any, though I do know that VST3 and VSTi are not supported. When using the current Audacity 2.4.2, plug-ins must be 64-bit (as far as I’m aware, 32-bit plug-ins are no longer supported by Audacity on macOS).

I am running Audacity 2.4.2 and MacOS 10.14.6. I also tried installing a set of vst plugins (http://mda.smartelectronix.com/) to my /Library/Audio/Plug-Ins/VST folder (I also tried the Audacity plugins folder). The plugins show up (as New) in the Audacity effects list but if I enable one it does not show up in the effects list and if I go back to the list it goes back to showing New. I figured that they must not be compatible for some reason with Audacity (?) so I deleted them from the Library folders. However, they still show up in Audacity’s list as New. First question: can these plug-ins be used with Audacity? 2nd Q: how to remove them from the list if they are not compatible? 3rdQ: where is the most comprehensive library of compatible plug-ins?

I don’t know. Perhaps one of the Mac people can answer that.

Unfortunately this is not yet supported through the graphical interface. The only way that I’m aware of is to reset all registered plug-ins back to the default (built-in effect and plug-ins shipped with Audacity enabled).
To do that, you need to delete the “pluginregistry.cfg” file. It is located in:

~/Library/Application Support/audacity/

where “~/” means your home directory.