Volume between recording and playing

Hello people,

I use Audacity for years now (thank you, the devs!), but since some time now, I have a sound balance problem when recording.

When I record, the recording volume is way lower than the playing volume. I need to level up the played volume to hope getting a pretty decent recorded volume. And that’s boring because it’s a bit random.

How can I adjust that, and get the recording at the same exact volume as the playing sound is? I tried to check the parameters but with no luck (and/or knowledge).

From what I can recall, for years I use Audacity, I didn’t have this problem before.

Thanks for the help, I stay available for any needed information.

Anyone, please? The Audacity team maybe? Thanks.

Problems with this depend on Audio Setup. Are all your devices listed in Audacity.
It also depends on settings within windows sound settings as well
and the sliders on the screen

Thanks for the reply. What do you advise me to check first, and please tell me where and how to check that.
After a few tests, I think the problem comes indeed from Windows and not Audacity, because I have the same problem when recording with Xbox Game Bar.


If you are on windows 10 or 11 go to setting sound and check all your devices are there and selected accordingly, and then see they are all listed in Audacity Audio setup.
OR on the taskbar tyoe control panle in the search box and to older more detailed control panel will open.
Go to sound and you can test and enable and disable each device.

Also If you are using any audio enhancements like Waves etc etc… disable it there is an option in cantrol panel sounds to disable it.
Make sure the windows volume settinf of your devices is set high enough

I’m on Win10.

I don’t know if it answers a bit your questions, but here’s what I can see in the sound settings:

I don’t have much devices linked to my tower, just the basic speakers and a subwoofer (Hercules XPS 2.1 40 Slim) for the sound in extern.

what are you recording and how are yoi picking it up… Linein oe Microphone they are showing not connected.

Is you Nvidia HDMI audio and video out?

Have you Stereo Mix anywhere in settings or maybe disabled. There is option to show disabled or hidden devices.

Are you just playing wav files or mp3 and recording them…what are your settings for that…?

Hello Audy, and sorry for the time of response.

I’m sorry but it seems that you’re speaking Chinese to me with your questions, I don’t get everything as my audio knowledges are weak. But I’ll try to answer.

I am recording the sounds from my PC, meaning I put the radio or play a video, or anything, and I record through Audacity. I don’t use a microphone, just the intern hardware. I listen to the radio through the radio station website and use Audacity by pressing ‘record’. And that’s here that I can see the acoustic signal that isn’t very large. It’s not flat, I have something, but it’s weaker than it should.

I’m talking about recording in intern, from a PC to the same PC. I don’t have extra cables behind my tower or so.

For the rest, please tell me where to check to get answers, like “go to parameters => sounds => etc.”, otherwise I’m afraid I won’t be able to know the answers.

But if everything is greyed in my devices, maybe we should try solving that, and it might resolve the problem? I don’t remember seeing those unable things, I think that’s the source of the problem.

Thank you for your help.

If you are recording from within your PC you will need Stereo Mix (that is the Microsoft name or Realtek name) enabled and installed. You do it all within windows settings or control panel. As it is not listed or geryed out in your earlier posts it is probably disabled or not installed. There are options to list hidded or disabled devices. In your Device manager you will see the sound card you are using in PC probably its inbuilt on the motherboard. Once you see it in the recording tab in windows control panel set it default and get green tick. For audacity to use it you will then need to set it as recording device in Audacity Audio setup.
The link below should give you some help. For more links just Google search windows Stereo Mix.
There is an option under Menu, Transport, Transport Options Monitiring, try those and have you the View, Recording Toolbar ticked and the slider up fully.
Also… Disable any enhancements such as WAVES audio etc until you get this sorted. enhancement can cause problems with setup. You can disable within control panel.

Stereo Mix not Working - Microsoft Community

But if everything is greyed in my devices, maybe we should try solving that…What exactly is greyed out in your recording tab in Sounds in control panel…?
here is another link…
How to Enable Stereo Mix if not Showing as Recording device in Windows 11/10. - WinTips.org

Thanks for the links. I checked them, but I couldn’t follow the methods as what I see in the screenshots and what I see on my own screen wasn’t the same.

Someone suggested me to download the Realtek drivers from their site.

I did, but I had an error message when trying installing it: https://i.goopics.net/0f17ph.png

So I searched for the 0001 error, and found that I have to download the drivers from my motherboard’s website (MSI). I took that (in the “On-board audio drivers” tab) and the installation could finish normally: B550-A PRO | Cartes mères MSI Pro

Then I went to the Sound window, and the Stereo Mix icon appeared! So I tried different configuration, but nothing changed. Then I wondered why I had no cable linked to my green hole at the back of my tower as usually, but I still can hear the sounds from my computer.
I followed my speakers’ cable, and the green jack was plugged directly into my monitor. That’s why I could see “U32R59x” in the Sound window and a little everywhere. I unplugged it from my screen and put it “back” on my motherboard (like I always did with my previous computers).

With this “new” configuration, I tried again recording sounds from my PC, but nope, it does record but the played sound volume is still way lower, whatever the options I put are. The acoustic signal is pretty flat.

With this new elements, I let you think of that. I still on my side, but I don’t know which other ways to explore.


There is nopoint in doing 101 things and then wondering which of the 100 things needs fixed.
There are 2 main aspects to this problem… it is either a windows problem or an Audacity problem.
For windows you will need to see your sound devices in setting sound for windows.
For Audacity after the windows bit is working you will need your devices selected in Audio setup in Audacity.
You need to fix or check problem in windows first.
It may be simpler to… type “Control Panel” into search box on taskbar and search and you should see it listed…click it , control panel opens, look for Sounds icon , click it and you should see the screens as in my last post. Post the recording screen and the playback screen or figure out what is doing what and what has green ticks. from your last screens posted it looks like your monitor is using HDMI for video and Audio (speakers inside monitor) that is why you hear sounds with the back leads not plugged in and thats OK for Audacity as long as Audacity is set to selecting the UR32R59 for playback…but then you say you have speakers…???
I didnt look them up but I assume they are amplified speakers with Linein …They should be plugged into the socket Lineout at back of PC and if you want to use them you need to select them in windows sound control panel instead of the UR32R59 and if you want Audacity to use them select them in Audacity. And make sure the sliders are up for playback in Audacity toolbars
““I don’t have much devices linked to my tower, just the basic speakers and a subwoofer (Hercules XPS 2.1 40 Slim ) for the sound in extern.””
This is all for Output sound…

If your recording is not working in recording tab select Stereo mix

Yes I have this Hercules XPS 2.1 40 Slim device, I use it to hear the sound of the videos or music I play on my computer. If you were confused about that, it surely is because of me and my knowledges in computering. By “intern sounds”, I meant the sounds that come out from the computer. I don’t talk about the bips the cpu mades, so first error from me I guess, I was speaking about YouTube or Winamp. For me “extern sounds” are when we plug a device at the tower and that it’s this device that is the source of the sound, the computer just being a player. Anyway, sorry for all that.

I was so bored with my problem, and I thought I was touching to the correction with my recent modification, that I retried just a few minutes ago, checking your links and the Audacity settings. And I think I succeeded fixing my problem! Of course I take no credits for that, you’re a big part of the solution, Audy.

In Audacity, I checked the general options, trying different combinations, and I got the right one by changing the recording device source. I know you told me to check that, but before my last try, I had only two choices and none worked, “U32R59x (NVIDIA High Definition Audio) (loopback)” and “Stereo Mix (Realtek Audio)”. But certainly because I removed the audio cable from the monitor to put it in the motherboard, I now have a third option: “Speakers (Realtek Audio)”.

So we can say that the problem was Realtek not installed and/or the audio jack plugged at the wrong place. I don’t know what would have happened if I’d have installed Realtek but let the cable behind the monitor.

I changed my PC last April, that’s why I said “not so long ago all was good, the acoustic signal was normal”. But with the sound coming from the speakers correctly, I couldn’t think there was a problem with the cable misplaced or Realtek missing as it always has been installed by default in my previous computers.

I can see this topic will automatically be closed in 19 days. I’ll use this period to continue testing my recorded/played sounds, see if it’s really fixed. I’ll let you know before it closes. But I think it’s fixed.

Thank you AudyMusik for your help, your suggestions and mainly your patience with me, I appreciate. ^^

No I am not confused.
You should read the two links I posted earlier…they explain the options.
For window settings…
Recording probably your setting will be “Stereo Mix”… But If you have a headset it may have a combined microphone and probably plug into front of Tower, so if it is plugged in you would also see headset mic in Recording tab as well and in order to use it you would have to select it in windows.
Playback… You will see your speaker if plugged in to your Lineout at the back and also you will see your Nvidia HDMI. ( And you will hear sound from monitor if your monitor speakers work over HDMI. Otherwise the monitor sound you were hearing was in via the Linein or Aux in on the monitor.??

For Audacity…In Audio setup…
You need to set … Host… Probably Windows Direct is best for your setup.
Also set Recording device… Probably “Stereo Mix” except using Realtek Line in or Mic in at the back or headset at front.
Also set Playback Device… Probably your Realtek Lineout to speakers at back or your UR32R59.

Also make sure the slider volume controls for each device in both windows and Audacity are set up. for both recording and playback

This topic was automatically closed after 30 days. New replies are no longer allowed.