voice recording got some high pitch noise

Linux = Ubuntu 18.04.5
Version =2.4.2-0build3+ubuntu18.04 (from PPA repository. )

I mange to get rid of background noise by using " noise reduction" effect. But whenever the speech start, there is some kind of high pitch distortion that I can’t get rid of. I’d be really appreciated if someone can give me advice on how to remove such distortion?

I attached a sample wave file for reference.


Too much noise reduction.

“Noise Reduction” is designed to remove constant, low level noise from recordings. If the noise level is high compared to the signal level, it will not be possible to significantly reduce the noise without also damaging the retained sound. The squeaky high pitched sounds in your file are typical side effects of too much noise reduction.

i tried to run just two time of noise reduction, and still can’t get rid of the noise. Can you suggest some setting for noise reduction effect ?

Also, I wonder if the noise came from the original wave file having too much high pitch background noise? i attached the clip from original wave file without tampering.

The kind of noise in your “258-5.wav” file is known as “digital artifacts” and is a common problem caused by certain kinds of digital processing including noise reduction and data compression. The “258_oroginal_recording.wav” file also has “digital artifacts” (that metallic bubbly sound) - not as bad, but definitely there.

The big problem with digital artifacts is that they are virtually impossible to get rid of. Additional processing only makes them worse, as can be heard in the processed “258-5.wav”.

Because “258_oroginal_recording.wav” is already low quality, I think the best that you can do with it is to reduce the level of that whistling sound using the “Graphic Eq” effect. Lower the 2.5k and 3.15k slider close to minimum (all other sliders set “flat” at their center positions). This is the result:

that setting help much on reducing the metallic bubbly sound. Thanks alot.

Not sure why the original sound capturing is bad. I use the mic from my noise cancelling bose headset on my lenovo p52. Not sure if there is any specific setting or driver i need to install? Or I simply need to get a dedicated microphone for higher quality of sound capturing? (eg. Blue Snowball ICE USB Microphone).

Headset mics rarely produce good quality, though you can sometimes improve the recording by turning off Windows Sound “Enhancements” (see: FAQ:Recording - Troubleshooting - Audacity Manual)