Voice delay in headphones when recording

Hi ,
When recording my voice I can’t use headphones because there is a big delay in the voice coming back to me. This makes it very difficult. The mic I use is a ‘Samson CO1U USB studio condenser’ on to my lap top computer. I am new to this tech area and would value any advice you may have. Thanks for reading.

When using a USB microphone, you must switch off “software playthrough” in “Edit > Preferences > Audio I/O”. (This is off by default).

This will mean that you cannot hear the microphone through your headphone, but that should not be a problem as you will be able to hear the live audio with your ears.

To be able to hear previously recorded tracks, make sure that “play other tracks while recording new one” is selected (on the same page in Preferences).

Hi Steve,
Thanks for the info, but is there a way to hear your own voice through the headphone while recording - would this mean a mic other than a USB ??

Yes it would mean using a microphone that is not USB. You can listen to the sounds from a USB microphone through the headphones only by using “software playthrough”, but this means that you get that delay problem. A lot of musicians get round the problem by listening to the previously recorded tracks with one side of the headphones over one ear, and leave the other ear uncovered so they can hear themselves sing/play accoustically.