Voice and Music are being recorded on the same track

Hi! I need your help because I am having trouble recording. My vocal and music are being recorded on the same track. I imported a music track and add another track to record my voice but when I tried to record, my music and my vocal are being recorded on the track that I added where it should only my voice be recorded. Is there any suggestions how to fix this? Thank you for the help in advance.

If you are recording by pressing the “R” key or clicking on the Record button, try holding down the shift key when you do so. The default operation was switched a little ways back supposedly to make things more intuitive. Go figure. :smiley:

Do you like recording Youtube music or other internet sound? The recording device for that is different from simple recording or overdubbing (what you’re doing). If you pick the wrong one, you’ll record both your voice and the backing track.

What does it say in the Audacity window next to the microphone?

Screen Shot 2021-06-17 at 6.32.06 PM.png

Yeah, I love recording from YouTube music. My problem is, my laptop doesn’t have 3.5 mm jack port therefore I am using a soundcard where I can connect my microphone and headset. I even selected it as my microphone and audio output but it’s still being recorded on the same track. I will try your suggestion first and I will be back. Thank you for this big help. :slight_smile:
Audacity Photo.PNG

I will also give this a try. Thank you so much. :slight_smile:

Hi Jademan,

I already tried to holding down the shift button as you suggested but it didn’t worked for me. Thank you for assisting me with this. :slight_smile:

The R and Shift+R thing was to straighten out the assumption that quite a number people (everybody) had that to “Add Sound” meant to add it to the end of the existing track. It didn’t used to do that by default and it does now.

You can make R work either way forever by changing a preference.

Audacity > Preferences > Recording > [X] Record On A New Track.

And yes, we’re always going to lose legacy users during a change like that.


If you are still having difficulties, see: Tutorial - Multi-track Overdubbing

I can connect my microphone and headset.

You threw mud in the game. Which soundcard?

There are two different overdubs. Simple and Perfect. Simple overdubbing means you perform with the backing track in your headphones. That’s it. Audacity records your voice (hopefully) on its own track and the first time you hear the combination is when you play it all back later.

Perfect overdubbing gives you a correct, theatrically perfect mix of both you and the backing track in your headphones during the performance. There’s more restrictions with that. You almost always have to use an external soundcard and the soundcard has to support mixing live and computer playback.

I reviewed three different soundcards which would to that including the Behringer UCA202.

There is a microphone which will do that.

Screen Shot 2021-06-18 at 8.36.52 AM.png

connect my microphone and headset.

Now it’s magic because you have two microphones connected.


Hi Koz,

You know what, I already figured it out. Thank you so so much for your help with me. Thank you for answering my questions and giving tips. Everything is good now. I just only needed to play Audacity so that I would know how I can apply effects to make my song more interesting. Thanks a lot. :slight_smile: