Vocal Remove Error

Hello! I’m tring to Vocal Remover plugin. I applied it and I got this error massage on debug mode:
“error: unbound function - |MAKE-STRiNG-iNPUT-STREAM|”

Which Linux distribution?
Which version of Audacity? (look in “Help > About Audacity”)
How did you install Audacity?

What were the exact settings that you used in Vocal Remover?
Were you applying it to a stereo track?
Was there an error message before the debug screen?

Ubuntu 13.10
Audacity 2.0.3
From Ubuntu Software Center

Remove Vocals, Simple, 500 2000
Yes, stereo.
No. There was no an error massage before debug screen.

Open Audacity, create a mono audio track and select it. Then from the Effect menu choose “Nyquist Prompt”.
Copy and paste the following code into the Nyquist Prompt text box and click the “Debug” button.
What happens?

(print s)
(setf test "1 2 3")
(print (read-line (make-string-input-stream test)))

“error: unbound function - |PRiNT|” and before that, “Nyquist did not return audio.”

Your Audacity installation is very broken.
This is not a “bug”, it’s a problem with your installation. Try removing Audacity completely (probably easiest to do with Synaptic Package Manage), reboot, then reinstall.
I can’t imagine what has caused this but it seems like several files are completely missing :confused:

Nothing changed :frowning: I can use other effects without any problem.

Do any of the following effects work?
“Adjustable Fade…”
“Clip Fix…”
“Cross Fade In”
“Cross Fade Out”
“Delay…”
“High Pass Filter…”
“Low Pass Filter…”
“Notch Filter…”
“Studio Fade Out”
“Tremolo…”
“Vocal Remover (for center-panned vocals)…”
“Vocoder…”

or these in the Analyze menu:
“Beat Finder…”
“Regular Interval Labels…”
“Sample Data Export…”
“Silence Finder…”
“Sound Finder…”

or these in the Generate menu:
“Click Track…”
“Pluck…”
“Risset Drum…”

Sorry for late answer. These effects don’t work. Only first part of effects (before 1-61 effects) running. I think the problem is Nyquist. :blush:

Nyquist is shipped as part of Audacity. I’ve used Audacity 2.0.3 in Ubuntu 13.10 and it worked fine.
Have you tried completely removing Audacity and reinstalling it?