Visible waveform but no sound

I was recording some gameplay commentary using a mic through the mic jack only. Audacity showed a waveform moving up and down when I spoke. When I was finished recording, there is no sound, only a faint hiss. I tried exporting to wav & mp3, no luck with either.

Anyone know why visible information on the timeline is being stored but no sound is occurring during playback?

Thanks for any help.

You can check if playback from Audacity is working by generating a tone in Audacity (Generate menu > Tone) and then playing it.
If playback is not working, check the playback setting in Device Toolbar .

Worked like a charm, I can hear the track now! Thanks Steve.

I have 2 separate tracks and part way through one of them the audio just stops playing, the waveform is still visible and I can hear the audio in the background of the second track as it continues to play.
I’ve tried generating a tone in that part of the track and it plays fine but still no audio that I recorded!

Sorry to violate the rules. I’m on OS X with the exact same problem. Waveform shows a recording but there’s no sound until a little further along in the track the sound starts. It’s one track, everything is properly set, nothing appears different after the sound starts.

The question is: how does the waveform indicate recording but won’t play it. And then it does.

Thanks for listening. I’ll go back to Mac Land now. But please let me know if someone figures this out.

What happens if you apply the “Amplify” effect to the waveform that does not play?
Which version of Audacity are you using?

I forgot to mention that the mp3 files created from the Audacity project showed that they had the amount of data that comparable files do.

To re-iterate:

Volume and wave meters show normal appearance for recorded sound.
Track is silent until the middle of the track when sound comes on.

How is this possible?

Crap. Sorry my previous post should have been in the Mac area. So never mind.