Very strange behavior on recording

I have just installed Audacity 2.3.0 and Lame mp3. I have turned off Menu > Transport > Transport Options > Overdub, which for some reason was On after installation.

I have selected the proper microphone for my HP laptop (Realtek Microphone Array) (when I select other input devices, there is no problem and silence is recorded). (When I open an existing mp3 file and simply play it, it plays perfectly.)

When I click the button with a red dot, recording begins.

But my voice is recorded very faintly and distorted. Also, the volume increases to a maximum and then decreases again, whether or not I speak aloud. Also, there is a strange sound that is the main sound that is recorded (my voice is very faint).

I have attached a screenshot of the waveform that is recorded when I am silent. It sounds like nothing I have ever heard before, a kind of fluid quick warble. I have also attached the exported mp3 file. If you play it, you will hear the strange sound.

At first I thought this was a problem with my computer, but then I remembered that I use my computer with Skype frequently to advise clients and it always captures my voice perfectly.

Audacity Screenshot.png

There was another poster with a similar problem. I don’t know that we ever solved it.

At first I thought this was a problem with my computer, but then I remembered that I use my computer with Skype frequently to advise clients and it always captures my voice perfectly.

That may appear to be the good behavior proof, but that may actually be what’s wrong. Skype is vicious about setting up your sound pathways to do what it wants and it doesn’t much care whatever else you want to do. Sometimes, the custom Skype pathways don’t get returned to normal when it closes.

I think the warbling is oscillation, a slow version of what happens at the club when they get the sound up too loud. The talking into a wine glass sound is echo and noise cancellation. That could be Skype holdover.

Some of that can be feedback from having a speaker running in the same room with a microphone. Don’t do that.

Make sure Skype is closed and not running in the background. Then Shift-Shutdown and wait for it to reset everything. Then start and see if it still does it, or the symptoms changed. Make sure Skype doesn’t start automatically.

Next time you post something try to get some Real Life in there somewhere like a human voice. If you post WAV in mono, you can go out to 20 seconds before the forum cuts you off.

Then you can go into Windows setups and make sure Windows isn’t trying to help you out.

https://manual.audacityteam.org/man/faq_recording_troubleshooting.html#enhancements

Koz

Koz, thank you for your reply. I did not receive an email notification, so I had given up on getting help for this problem. But I looked at the forum just to be sure, and saw your answer.

I am interested in this theory that Skype is to blame. If it has made a change to my computer, I cannot see it. As you know, Windows is not transparent as to what is actually happening within it.

I do not enable any monitoring (sound output) during recording, so this cannot be straightforward feedback oscillation. But I agree that it looks just like it.

I always keep Skype closed when I am not using it, as I only use it for talking with clients.

I don’t know what you mean by recording “real life”, but I think saying, “test, test, test…” is an adequate test. Such testing has always worked in the past throughout the years. In the current situation, my voice was drowned out by the oscillation.

I followed your advice to shutdown fully and restart. I then ran Audacity and the same problem was again seen. I looked at the Sound properties and found no user-changeable controls. I did find that the correct microphone device was NOT selected as the default device and corrected that. But this could not cause the problem because Audacity reported the correct input and output devices.

I then downloaded and installed the latest version of Goldwave. I made sure its input and output were set up correctly, then recorded myself again saying, “test, test, test…”. Approximately the same thing happened! I saw and heard the same recorded garbage.

This proves that the problem is not with Audacity, but with HP (manufacturer of my laptop) or with Windows 10 Home.

So you have no responsibility to try to fix this. It is quite a puzzle.

By the way, I am subscribed to this posting, and my notifications are set to send me email, and my email address is correct in my profile.

But I did not receive a notification when you posted your previous reply! Could be a bug in your forum software.

The “subscribe topic” setting is a bit weird in this version of phpBB (the forum software). To subscribe to the topic you need to click on the setting so that it is NOT ticked.

You can check which topics you are subscribed to by looking in the “Overview > Manage Subscriptions” section of your “User Control Panel”.
To access the User Control Panel, click on your name near the top right corner of the forum.

I honestly do not understand the reply about notifications.

Currently, I seem to be subscribed ONLY to my posting “Multiple instances in multiple windows?!”. But there is a checkbox at https://forum.audacityteam.org/ucp.php?i=ucp_main&mode=subscribed that is labeled “MARK”!! What can MARK possibly mean? And how can I subscribe to THIS posting when I am already subscribed to it?

I’ve looked at the phpBB forum and they don’t have this issue so far as I can see. I’ve also done a web search.

In my opinion, simply replying to a posting in a forum should subscribe one to email notifications, assuming that no preferences have been set. Also, in my opinion, each posting should have an unambiguous way to subscribe: if you are already subscribed, there should be an “unsubscribe” button, and vice versa. Again, just my opinion.

It is quite a puzzle.

It is that. All the king’s horses and all the kings men…

The desperation method is stop using the computer. This is a Zoom H4 sound recorder.



The mechanical support and acoustic isolation is from Scott Paper Co. and the desk deadening cover is a furniture moving pad. The coffee is from Cafe Milan. The room is reasonably quiet and we’re done.


That clips passes ACX Check for audiobook sound standards conformance.

Koz

It means that you can mark with a tick in the checkbox, any of the topics that you are currently subscribed to (any topic that is listed there. At the bottom of the list is a button “Unwatch marked”. If you click that button, then you will be unsubscribed from all topics that you have marked.

Please note that we do not make the forum software. We just use it.

There is a user guide for the forum software here: phpBB • Free and Open Source Forum Software

Koz, I enjoyed your posting! If I ever wanted to make really high quality recordings, this would be a great way to go.

I guess I’ll have to record on another computer. Over the years I’ve accumulated several; most are capable of good-quality recording. Either Windows 10 or HP should hang their head in shame. Too bad I don’t know whom to blame.

Thanks also for your excellent help with the forum. I think I’m okay with that now.

PS - I’m glad the Hudson Valley cows have plenty of lush grazing land.

this would be a great way to go.

There is a ‘gotcha’ in there. That quiet room is not easy to achieve. The current fashion of lushly polished hardwood floors and plain white, uncluttered walls is regarded as a viciously hostile recording environment.

You might do better in your disaster of a garage. Deaden the inside of the door with a couple of furniture pads and record your brains out. The more cardboard boxes, the better.

Koz

I’m glad the Hudson Valley cows have plenty of lush grazing land.

The Hudson River School didn’t just make that up.


Screen Shot 2019-01-19 at 12.00.52.png


Past the brush technique, parts of the valley really do look like that.

Of course, that’s Summer. The other three seasons are a bit grimmer. Pre-Winter, Winter, and Winter-Recovery.

Koz

What you’re describing is consistent with what Window’s “enhancements” can do,
try disabling them, (all of them, in recording & playback tabs), see … https://www.youtube.com/watch?v=sxnUjiGgBaI

Also ensure "software Playthrough of input" is unchecked.

GoldWave (which I used to use frequently, years ago) can make an ordinary room in a house work well for nonprofessional high quality recordings. With a bit of work, it can remove echos, the sound of a fan, and other artifacts. Howver, going back to the first post of this thread, I will not be able to record under any conditions with this crappy, brand-new Windows 10 computer. Everything in our society is losing quality as wealthy people and the financial institutions continue to extract wealth out of our currency supply.

Recently half of my toaster oven burned out and I researched buying a replacement. Incredibly, it turns out that there is not one reliable toaster oven available for sale for less than at least $400. There are plenty of $30 models, but every one has poor ratings due to front-door glass breaking or exploding, difficult-to-turn knobs, front panel labels that scrape or rub off easily in normal use, etc. Every one is made in China, under similar design and financial constraints. Today it is already true that one can no longer find a reasonably-priced toaster oven. Tomorrow many more types of products may follow suit, including computers.

It sounds like your computer is misconfigured for what you want to do, rather than defective.

I don’t think your problem is with Audacity, but if you are open to trying other Audio editors try OCENaudio (freebie).

[ Double-check “software Playthrough of input” is unchecked first ].

“software Playthrough of input” is already unchecked.

As I already said, the problem happens with three unrelated sound recorders. That’s enough testing, thank you.

The only remaining strange issue is that Skype works perfectly. So I’m inclined to agree it’s a configuration problem. But until/unless I find another similar posting on the Web, it’s likely to remain a mystery.

Thanks to all for your help. If I ever find a solution, I’ll post it here.

If the Window’s enhancements have been disabled, and the problem persists, the only other thing I can think of is “Realtek microphone effects”, (which are similar to the “enhancements”) …

Although I haven’t found the Realtek HD Audio Manager, I did find “B & O Play Audio Control” in the Control Panel. Running this and selecting Input revealed an option called "HP Noise Cancellation > Only My Voice, Multiple Voices*. Turning this option Off eliminated that horrible feedback sound, but left two remaining problems: a high noise level, which sounds like the disk drive (the microphones are built into the laptop case!), and a low volume for my voice, even if I speak directly into the microphones. Also, the balance between channels is wrong (L is always lower volume than R, no matter which microphone I speak into).

I also tried with an external microphone, with the same results. Horrible sound.

But this is real progress, thanks, even though I still cannot record acceptably. It is so weird that everyone can hear me clearly on Skype, when I am speaking some distance away from my laptop.

It is so weird that everyone can hear me clearly on Skype

It is not.

Skype became the premiere conferencing and communications app by taking over your computer during the conference and creating settings that enhance its operation. A complete basket case computer can produce a clear Skype call on command and then return to being a basket case when it’s done.

There is a down side to this activity. Everybody wants to record both sides of a Skype call for their podcast. That’s not hard, is it?

It’s impossible. The minute you start to mess with sound conditioning, you run into the snarling bear of Skype settings. I and several others got around this with two computers. One you leave alone running Skype and the other does everything else—like record the show. It got so bad that Skype offers a podcast recording service—in the cloud—that will record your Skype production and then send it to you later. You don’t record anything.

So that’s what you’re dealing with and that’s why I ask about Skype right at the top of a diagnostic process. You do not want to leave Skype running in the background while you’re trying to do something else. You inherit the Skype settings and really bad things can happen.

In the middle of this pop up the celebrity unicorns. Chase is one of these people with his brother across the country. He ran Skype and Audacity, created his good quality, clear podcast over many hundred miles and he’s looking at the rest of us like we’re nuts. He got insanely lucky. Nobody else can do that.

Drive and power supply noises.

Welcome to recording on a computer. This is another reason recording sound on a computer is not for the easily frightened. Behold my podcast test studio.

Both of those Macs have Solid State Drives that make no noise in normal operation and unless stressed, the vent fans make no noise.

I have created sample test clips on this machine, a MacBook Air, using the built-in microphones. Again, in normal operation, it makes no noise and I did it in a quiet room.

I wouldn’t do regular production like this, but I did do a production sound shoot of someone whose voice was going to be used as a “stand-in” for the real actor who would appear later. It worked perfectly and they slipped the temp voice right into the show and kept going.

Just the machine and its microphones. Nothing external.

I have a guideline for this. If you can tell the computer is on just by listening, you’re going to have an interesting time.

That H4 is looking better and better, isn’t it?

Koz

I don’t have Windows 10, but it apparently has an automatic “audio troubleshooter” feature …
https ://support.microsoft.com/en-us/help/4026994/windows-10-fix-sound-problems

[ I have never tried it ].

What makes you think I am running Skype in the background? I have already said that I close Skype when I am finished with it. I just ran Task Manager and there is no entry for Skype!

I will search the web when I next have time to see if there are any problems like this reported for Skype. I will see if Skype leaves computers messed up. I’ve not heard of this before this current thread.

So far as recording Skype calls are concerned, one website I use has recorded hundreds of beautifully clear calls, both sides. There are a number of apps, some free, that can do this. I am sorry to hear that you have had so much trouble recording Skype calls.

No Windows 10 troubleshooter is any good. I say this from long experience. They either ask some stupid questions then give up, or they ask you to do really invasive things, like restoring your computer.

I thank you all for helping, but at this point you are not really helping anymore. Let it go. Again, if I find a solution I promise to report it here.