Vertical red line and high pitched noise when Record is activated

I have two issues.

Firstly, I cannot get rid of the vertical red line, which I understand is Quick Play. I have tried to disable Quick Play by right clicking on the Timeline, but it did not go away. Now when I right click on Timeline nothing happens. I have quit Audacity several times, but the red line is always there when I re-open it.

Secondly, when I click the Record button, I get a high pitched oscillating noise. I am using an Audio-Technics AT-LP120-USB turntable. It connects to my Mac computer via USB cable. I have gone through my system, and the high pitched noise is only present when the record button is pressed. When a record is played without it being recorded the noise is not there. I have replaced the cord to no avail, and tried inserting the cord into the other ports on the back of the Mac. Still makes no difference. I am using Audacity 2.3.3 and Mac Mojave 10.14.6. This noise was occurring before I encountered the red line problem.

I have used Audacity for many years and have not run into either problems before. I only use it for transferring records to digital files.

I hope someone can help me.



To stop the squeal when recording, try unchecking “software playthrough” in Audacity preferences.

The ‘software play through’ is already unchecked, but thanks for the suggestion. Until I get rid of the red line I cannot record anyway …

The red line is normal when recording, but it should be moving if there is sound being input …

The squeal when recording means there is a feedback-loop somewhere,
unfortunately I don’t speak Mac, so I can’t help you with that.

When I hit the Record button the red line moves a fraction and then stops. In other words it is locked a split second along the timeline. How do I unfree it?

Check that “Sound Activated Recording” is not enabled in
“Transport menu > Transport options”

Thank You Steve - that certainly got the red line moving. But now I see no signal coming in when I hit Record. Previously I had Sound Activated Recording checked and it would record when the needle touched the record. I’m going through the manual as if this is the first time I have ever used Audacity to check whether I am making an elemental error, but have found nothing yet.

Found it … reason it wasn’t recording was because Audacity was unchecked in Apple’s Microphone section in Apple Preferences’ Privacy section.
Also, the feedback problem is resolved by unplugging the Audio out from the back of the computer while recording.
Thanks everyone for the help.