Version 3.4.2 Sucks!

Just wondering, how can I revert to my old version 3.3.3 because I am not getting no sound from the new version since I have switched. Using windows 10. I really had no issues with the previous one, and now I am unhappy as I am not hearing anything from my recordings. Please HELP!

Older versions here

It does SEEM like the new Muse team is more “casual” about releasing new versions but I don’t know what’s going on behind the scenes and it might just be an impression…

You need to tell us which computer type you have. Just downgrading the Audacity version doesn’t cover everything. You also have to reset Settings and Preferences so your 3.4.2 problems don’t follow you to 3.3.3

Koz

I never had a problem with the old 3.3.3 just wanted to upgrade since the new version is out and now I cant hear my recordings. I am using Windows Lenova 320. I am so sorry that I ran to this new version that has so far given me nothing but headaches when I have a deadline to fulfill.

https://manual.audacityteam.org/man/reset_configuration.html

Audacity keeps settings and preferences separate so you don’t have to reconfigure Audacity from dead zero every time you change the version. The down side of that is having a bad setting follow you like a head cold.

Koz

The is where the Obsessive Engineer will tell you never update or change anything in the middle of a production schedule.

Windows makes this particularly challenging by forcing updates whether you want them or not. I think you can get around this by not connecting your machine to the internet during production.

Ahem…or use a Mac.

Koz

Windows makes this particularly challenging by forcing updates whether you want them or not.

Windows 11 Pro doesn’t :slight_smile:

I will look that up. Everything Windows I do is rumor, innuendo, and guess work (he said, typing on his Mac).

That would save a lot of production headaches, if true. I was composing a forum question about how to avoid auto updates.

I don’t know that your production headaches are going to follow you backwards from 3.4.2 to 3.3.3, but if they do, that’s how to clean out the closet and start over.

I believe Audacity 3.4.2 pays a lot more attention to connection, device, and environment security. If your playback is going through a fancy, external headphone system, we may have located the problem. Audacity doesn’t have permission to connect.

Koz

There was pretty much no changes to the way how Audacity works with audio devices since 2021 when PortAudio 19.7.0 was released.

macOS does break stuff in Audacity in some releases, though.

Is your input volume slider set to 0% perhaps?

I already tried that -switching back to the former 3.3.3, as it was user friendly. But Audacity got clever and removed the web page as it gave me a 404 then ‘not found’ :unamused:

This 3.4.2 I discovered you must tweak a few of your settings to get it to operate like the former. After a few meltdowns as it was going like crap, until I did so under Edit/Preferences. Pain in the tuke, but I managed :slight_smile:

1 Like

Can you please clarify?

Clarify as far as …? Perhaps re-worded… when I clicked into the weblink on the Audacity site page for the older versions incl. 3.3.3, it opened to a dead page 404 with the error note “not found”

the link to https://www.fosshub.com/Audacity-old.html works for me, both the one posted at the start of this thread, and the ones on the Audacity website.

Also every release starting from 3.0.0 can be downloaded from GitHub: Releases · audacity/audacity · GitHub

This topic was automatically closed after 30 days. New replies are no longer allowed.