Version 3.2.5 - not responding

Hi Guys!

I’ve been recording a demo using the newest version (3.2.5). I’ve completed laying down all the instrument tracks and have one more track to add (vocals).

Before adding the last track, I began reviewing the tracks and doing some timeline editing of a particular track. I began using the timeshift tool to line up certain beats with the other drum track. This involved doing a little cutting and pasting of my percussion track with the other drum so that they will be perfectly syncopated.

I found a section within my percussion track that needed aligning but I didn’t like the way it sounded when I played it back on SOLO mode. So I decided to go back to the beginning of the track to find a section that I could utilize using the copy, cut and paste option. I found the audio sample I wanted and I copied it. When I did that, I noticed that the Audacity response to my actions were sluggish after copying. When I tried to paste the copied section to the percussion timeline, the program began to buffer and the message “not responding” appeared at the top. I’ve tried hitting “ESC” to see if I could unfreeze it but to no avail.

I can’t move forward with my project because Audacity continues to freeze up everytime I try to cut and paste. I have force closed the program twice and when I reopen Audacity, a popup window says that it wasn’t closed properly and it recovered my file. I’ve tried to duplicate the track in question to see if I can cut from the duplicat to paste onto the original percussion track and it did not work (did not paste, then program froze/not respond). I’ve also tried to reinstall Audacity to see if it would fix or replace any corrupted file(s) and it still freezes/not responds. Are you guys working to fix this bug?

Please HELP!

Just to be on the safe side, make a backup copy of your project before you do any additional work on it.

How many tracks do you have?

Make sure you don’t have any audio in negative time. If you do, Select All, then drag the entire project to the right as required.

Due to a design “feature” when you copy even a tiny selection from a much larger track, the ENTIRE track actually gets linked. It is not visible, but it is linked. The problem is when you do this copy from one project to another. In this case then ENTIRE track actually gets COPIED into the new project, which in most cases not what you actually want. The developers are hoping to include an option in 3.3 to avoid this nuisance copy.

To clean up your existing project, you can do Mix and Render on individual tracks. This releases that extra (unseen) data.

To avoid this undesirable copy in the future, first copy the selection to an NEW track in the OLD project, and do a Mix and Render on this new track. Then copy the newly rendered track from the OLD project to the NEW project. This way, only the selected portion will be copied.


I have 9 tracks - 1 click track, 3 percussion tracks, 1 backing track and 2 minor percussion (hand bells) track.

None of my tracks appear to be in negative time.

I have uninstalled Audacity, ran a Windows 10 compatibility scan, checked my graphics and audio drivers for updates and everything seems to check out fine. I still get sluggish response and freeze ups.

OK. Did you have a chance to do a Mix and Render on each individual track ?

Hi, Did you find a solution to this problem. You have described exactly the same problem I am having. I have one click track , 1 percussion , 1 backing , 2 vocals , 3 twiddly bits (synth) , and Bass. I am doing a final tidy up and doing copy /paste of some bits to other tracks or the same track , it seems to be working then it just freezes with “Not Responding”. Cant get out of it without closing. The “snapshot” recovery seems to work after re-running Audacity, but after some simple edits it freezes again. I see there is a new 3.3.0 BETA version , hopefully the problem will be sorted with that.


I was advised by “jademan” to follow this solution tip…and it WORKED! I hope it will work for you, too:

MIX and RENDER EACH INDIVIDUAL TRACK. After you do this to EACH TRACK, you must close Audacity and re-open it again and REPEAT THE PROCEDURE until ALL TRACKS are MIXED and RENDERED.

After I did this, response to commands were instantaneous and there was no more sluggishness/freeze ups.

Good luck!

BongoDude, Yes, thank you. :grinning:

metrodave, I don’t think just loading your project into 3.30 BETA will fix the issue. However, it is entirely possible that if you load your old project with the BETA, then Select-All, then Ctrl+C (Copy), then File > New, then Ctrl+V (Paste), then select "Selected Audio Only"when prompted; that this will correct the problem in the New project.

Hi, Thanks for that. I will give that a try. It does make sense what JADEMAN said in that even very small bits of a track link the whole track to the copied position. In my case there are quite a few of those so seems like its getting in a knot !! Cheers.

This topic was automatically closed after 30 days. New replies are no longer allowed.