Version 2.4.2, Opening an mp3 file for editing - something about FFmpeg [SOLVED]

I normally just use File/Import/Audio and select an mp3 track. Now I get a message about FFmpeg and I cannot import the mp3. The message gives two options, the first says to go to Edit/Preferences/Libraries, where you have options to locate or download an FFmpeg library. Following these links does not help. The second option is to import RAW data, but that just plays as fuzzy noise.

I’ve tried looking up what FFmpeg is, it means nothing to me. It seems to be software that will work with file formats beyond mp3 data, which I’m not doing. I found various links to pages that talk about FFmeg, but in techno speak, I don’t want that. If I need to download an add-on to Audacity I just want a link. If I need to change a setting I just need instructions with a path. If Audacity doesn’t do this any more I just need to know and find alternative software.

Two hours gone now on something that used to take less than 10 minutes!!!

Thanks in advance.
Screenshot (19).png
Screenshot (18).png

You can take this upside down. You can check if you have a healthy MP3 because Audacity will open those.

You can find out what you really have with MediaInfo.

And yes, you can add the FFMpeg software to Audacity to open many different sound formats.

If you’re absolutely double-dog sure you have an MP3, then it could just be so broken that nothing will open it. Does it open in Windows Media?


Where is D:? Is that a cloud drive?


Thanks. Yes it is mp3, see attached. Interestingly, some files are opening, and some are not. The ones that are opening still display the first FFmpeg message window and then open. I keep all my music on an external hard drive attached to my pc. The tracks are still playing ok through a media player, it seems to be just an issue for Audacity.
Screenshot (20).png

And playing…
Screenshot (21).png

There’s a few possibilities of where the problem lies.
Do you get the same error in Audacity if you move the file to your Desktop, and then import it from there?

Yes, so the location of the file is not the issue…

In that case it would seem that there is something a bit peculiar about that MP3.
To confirm that, let’s make sure that you are able to import a standards compliant MP3. Download this test tone and see if it will import. It’s just a 10 second beep (it’s quite loud):

Do the broken ones have parentheses in the filename?

Do the broken ones straighten up if you change the filename in Windows? Upper case, lower case, numbers, underscore and -dash- only. No spaces.


The Test Tone loads and plays, but the first FFmpeg message window does appear.
The track has no parentheses or anything odd in the file name, see images.
Screenshot (23).png
Screenshot (22).png

Which is “the first FFmpeg message window”?

This one
Screenshot (18).png

Are you certain that you are using Audacity 2.4.2? Look in “Help menu > About Audacity” to check.
Where did you get Audacity from?

A few weeks ago when I opened up Audacity it said that there was a newer version and took me through the update. So this is the version and it came from the previous version.

I was thinking maybe it’s possible to get the previous version from a link somewhere and uninstall this version.
Screenshot (24).png

How did Audacity do that? Did you select “Check for updates” from the Help menu, or did Audacity just tell you when you launched the program?

It’s not something that I recall exactly. The last time that I used Audacity I was trimming an audio file, so it would have been then. I would not have gone looking for an update unless I’d had a problem, which I did not. So I assume that a window message appeared prompting me to do an update. Your questions seems to suggest that somehow I’ve been taken off piste and found myself with a fake version or something?
Screenshot (25).jpg

Audacity does not prompt for updates. You can check for updates in “Help menu > Check for Updates” (which opens your default web browser on the Audacity website download page: Audacity ® | Downloads), but Audacity will never take it upon itself to prompt you unless you explicitly select that option.

Perhaps you have some security app, or an auto update app that prompts you? I think it’s worth trying to find where that prompt came from, because it didn’t come from an authentic version of Audacity.

I’m not going to be able to figure out now what caused me to take the update, so that will have to be parked there.

But, to resolve my initial problem, you seem to be suggesting uninstall the version that I have and install again from scratch? I’m not really sure why you are questioning the version that I have installed. A quick look suggests the current version is still 2.4.2, but I can see that there are optional additional downloads for Plug-ins and Libraries. So is there a reason why you think that there is something wrong with my version?

If a program does something (such as telling you to download an update) which the program does not have the ability to do, then that rings alarm bells for me.

Audacity ® | Download for Windows” is the correct website, so I’ll assume that it is a false alarm - as I previously wrote, it could be a security program being helpful that was prompting you.

That’s weird. When importing a valid MP3 file (such as the test tone that I posted), FFmpeg should not be involved at all, and there should be no error message.

What do you have in:
“Edit menu > Preferences > Import / Export > Extended Import”
By default there should be two empty lists.

I’m only really saying that I cannot recall why I updated, but I cannot see any reason why I’d just open it and look for an update unless something was wrong. Usually I want to open it, use it, close it and move on. It’s too long ago now.

Maybe I should be trying these links from the download page;

Plug-ins and Libraries
Plug-Ins – Download additional effects and filters.
FFmpeg import/export library – Allows Audacity to import and export many additional audio formats such as AC3, AMR(NB), M4A and WMA, and to import audio from video files.
Screenshot (26).png