Using WASAPI to record desktop audio, Error code -9996, Blue Yeti Microphone

I’m trying to do some audio recordings on my PC using the Blue Yeti and Audacity, specifically I want to record microphone audio as well as desktop audio (from Discord). I read on the Audacity website tutorial that in order to enable desktop recording I would need to switch to “Windows WASAPI” as the Host, and to choose the active microphone -in this case (Yeti Classic) (loopback)- as the recording device. In this case, I’m also using the (Yeti Classic) as my playback device as I have a headset connected directly to the microphone for output. I’ve followed the tutorial on the Audacity website exactly, but when I press record I get “Error code: -9996 Invalid device”. I have been Googling this issue for hours trying to find a fix but nothing I’ve tried has worked. So far some of the fixes I’ve tried:

-Changing the recording Channel between Mono/Stereo (neither works)

-Changing the Project Rate (hz) in the Audio Setup>Audio Settings>Quality menu

-Changing the (hz) rate of the audio quality in Windows settings (sound settings>sound control panel>[double click both the recording/playback devices>advanced>default format drop-down] between the two available options (44100hz & 48000hz)

-Making sure the selected (hz) rate matches in both Windows & Audacity, regardless of which I’ve chosen (neither works)

-Attempting to update the drivers for the Blue Yeti & trying all previous options again (I’m pretty sure it was already on the latest version anyway)

-Rescan audio devices like 50 times (usually after each change in Windows) & try again

-Opening up privacy options in Windows (allowing Apps/Desktop apps to access the microphone)

-Checked all physical connections

None of it has worked, nor has any combination of those fixes that I have tried (probably all of them at this point). I also read on the Audacity troubleshooting page that “Due to a Windows limitation, you cannot use WASAPI on a USB device while listening back on an onboard audio card”, however I’m using the same device (Yeti Classic) for both input and output, which is listed as a workaround.

I’m running Windows 10. I’ve included a link below with some photos. Any help would be greatly appreciated. Thanks in advance.

the issue ended up being caused by the Logitech G-Hub software. it must have been preventing audacity from recognizing the microphone somehow. after i uninstalled it, the issue was cleared. it also changed the name of the device in Windows from “Yeti Classic” to “Yeti Stereo Microphone”

This topic was automatically closed after 30 days. New replies are no longer allowed.