Using FeSTige on KXStudio

Hi everyone,
I noticed in the Audacity wiki that there was interest in knowing more about how well FeSTige works with Audacity. I might be able to help! :wink:

I’m using KXStudio, and trying out lots and lots of VST instruments (synths). So far, here are the ones (freeware mostly) that I have had “problems” with Audacity crashing when trying to record in realtime:

  • Disphase

  • Micromoon

  • PG8x-1

  • String Thing

  • Artphase 1.0/1.5

  • Vosc8

  • Formant Classic

  • Extractor

  • 1984

  • JEM

  • TruthSynth

    In addition, Audacity doesn’t “see” the following synth when I do a “rescan audio devices:”

  • Phadiz.

    My thinking is that the creators of these synths didn’t put something in their app that the others that do work have. But, if Audacity can be made to “accomodate” these synths, too, all the better! :slight_smile:

    Hope this helps!


You mean you were playing the synth in FeSTige and recording its playback in Audacity using JACK?

Audacity only supports VST effects, not synths, and only on Windows and Mac, so are you saying that the synths appear as individual recording inputs in Audacity’s Device Toolbar?


Right. Audacity sees most of them, but the problem is that some crash when I try to record.

The VST instruments are hosted by FeSTige (included in the KXStudio installation), and when I do a “rescan audio devices” it then appears next to the audio input selector. (I am using Jack.)

A couple more that I have found crash in Audacity recently:

Extractor. (I got all these from

Keeping in mind, that these are the ones that have caused a crash; out of more than 100 VSTs. So the vast majority work fine. :slight_smile:


I found some very nice VST instruments on this website:

In particular, one called “4Evar” that I really like. But alas, I have to record audio using a DAW (which I don’t prefer because there’s too much set-up to do), since Audacity crashes when I click “record” after I have selected Transport>Rescan audio devices and selected “4Evar” in the Input Device tab.

Like I said, the majority of VST synths work just fine, so I think it’s the VST programmer that left something out of the instrument development.

But, if Audacity could somehow work around this, it’d be really neat! :wink:


So when you start FeSTige and Transport > Rescan Audio Devices in Audacity, “FeSTige” appears in Input Device in Audacity’s Device Toolbar? Then when you add a VST to FeSTige and rescan, that VST is added to the input device list as well as “FeSTtige” (or does “FeSTIge ” replace "FeSTige ")?

Does it make a difference to the crashes if you only have one VST at a time loaded in FeSTige?


No, “FeSTige” doesn’t appear. The VST instrument that is being hosted appears. (One VST instrument didn’t appear at all, it’s called Phadiz.)

FeSTige never appears in the Toolbar (and it probably shouldn’t anyway, I think).

I’ve never tried loading more than one VST at a time. For now, I just use one VST at a time (and not .exe-type VSTs, only the .dll ones).


Thanks for the clarification.


I suppose I could open Audacity from a terminal, and see what it prints out when it crashes… if it would help you.

I also sometimes click “send” on the crash notice when it happens, so I suppose you have the info somewhere already…

Let me know if I can help in any way. I really prefer Audacity for its simplicity.


Usually the terminal messages are not detailed enough to show what exactly went wrong.

Ideally you would build the debug version of Audacity (or install the dbg package of Audacity supplied by your distro) then launch the gdb debugger then launch Audacity from gdb. When the crash happens, type bt and hit ENTER to get the backtrace.

We don’t receive reports, they must go to KXStudio or Ubuntu.



Hi Gale,
I installed the debug file from synaptic, and tried to run dbg audacity in the terminal, but I don’t see the audacity gui. Am I doing something wrong?


I think you need to type “gdb audacity”:

$ gdb audacity

and then type “run”

$ (gdb) run


Got it! :slight_smile:

Ok, I ran a VST that I knew would cause a crash, called SuperwaveP8. Here is the output when I typed “bt” in the terminal:

#0  0xb7fdd424 in __kernel_vsyscall ()
#1  0xb5ca91ef in raise () from /lib/i386-linux-gnu/
#2  0xb5cac835 in abort () from /lib/i386-linux-gnu/
#3  0xb5ce42fa in ?? () from /lib/i386-linux-gnu/
#4  0xb5ceee42 in ?? () from /lib/i386-linux-gnu/
#5  0xb5f1351f in operator delete(void*) ()
   from /usr/lib/i386-linux-gnu/
#6  0xb5f1357b in operator delete[](void*) ()
   from /usr/lib/i386-linux-gnu/
#7  0x0813c5b3 in AudioIO::StartStreamCleanup (this=0x885d468, 
    bOnlyBuffers=false) at AudioIO.cpp:1422
#8  0x0813f1b7 in AudioIO::StartStream (this=0x885d468, playbackTracks=..., 
    captureTracks=..., timeTrack=0x0, sampleRate=44100, t0=0, t1=1000000000, 
    listener=0x90de728, playLooped=false, cutPreviewGapStart=0, 
    cutPreviewGapLen=0) at AudioIO.cpp:1372
#9  0x082f5c97 in ControlToolBar::OnRecord (this=0x9228910, evt=...)
    at toolbars/ControlToolBar.cpp:912
#10 0xb7a27038 in wxAppConsole::HandleEvent(wxEvtHandler*, void (wxEvtHandler::*)(wxEvent&), wxEvent&) const ()
   from /usr/lib/i386-linux-gnu/
#11 0xb7ab678a in wxEvtHandler::ProcessEventIfMatches(wxEventTableEntryBase const&, wxEvtHandler*, wxEvent&) ()
   from /usr/lib/i386-linux-gnu/

Hope this helps…! :slight_smile:


Thanks, Brian.

I’ll post here if more information is needed.


Ok! :wink:


Just an update:
I’ve been trying out Reaper, which is also included in KXStudio (demo version). And I’ve tried a couple synths that were previously causing Audacity to crash when using FeSTige. But in Reaper they don’t crash. I guess since the input device that shows up is not the VSTi, but Reaper.

So at least in Reaper things seem fine… :slight_smile: