Using Audacity after ASIO compile

I am a long time Audacity user and recently had it compiled with ASIO by a much more computer literate friend.
This compiled version does not show anywhere that it is using ASIO however: the interface host still shows three options: MME, DirectSound and WASAPI.

Am I missing something?

Also, can someone please confirm that ASIO indeed helps in the exporting process, as in preserving the full word length (24 bits) of saved samples, which is what I was lead to believe? I use Audacity solely for editing already recorded files (TASCAM digital recorder) and would like to maintain as much as possible the quality of this original vinyl rip.

Thanks in advance for enlightening me,

That’s not correct. For audio that has already been recorded, Audacity will (by default) import lossless audio files as 32-bit float. Converting from 24 bit to 32 bit float is lossless.

You don’t need ASIO.

Thank you very much for that.
How about if those files then are played through a DAC that is run via the COMBO384ASIO driver?

If you are using an ASIO driver for your audio device, then an ASIO build is required.
In an ASIO enabled build of Audacity, ASIO will be available in the “host” selection of the Device Toolbar but only if ASIO is already running when Audacity is started.

Note that most audio devices that use ASIO also support WDM, and WDM drivers are supported by using the “MME” option as “host”. It is not possible to use an audio device with ASIO and WDM at the same time, it’s one or the other because ASIO requires exclusive access to the device.

Thank you both to responding to my questions. I now understand what has happened and why I actually needed ASIO in the first place. A long time ago ripped my records using the Lynx L22 soundcard and Audacity, for which I needed ASIO in order to get the full 24 bit capture capability of this chain. After I chose TASCAM as my digital recorder, which has its own HDD, I only used Audacity for editing the already recorded files, for which ASIO obviously isn’t needed.
Problem solved!
Cheers everyone