USB recording device doesn't show up

Using a cassette device to transfer recordings to PC. I am assuming that when I go to Preferences and the drop down for Recording Device, I should see some sort of USB device. But it doesn’t show up. Tried restart of audacity and the rescan devices option but nothing. It seemed like in one try there was a USB device showing and the recording actually worked but then it recording stopped working and the device no long shows up. Are my assumptions correct on the recording device? any ideas on solving this?

Right-click on the Windows Volume/Speaker icon and go through the windows to see if it shows-up as a recording device. If Windows sees it, it will usually work with Audacity and of course if Windows doesn’t see it Audacity won’t see it.

Have you tried a different USB cable? Or maybe the cassette player just died…

In your other post you said you’re using a desktop computer. If the headphone-output on the cassette player works, you can connect the headphone-output to the blue line-input on your regular soundcard and record that way. (The microphone input on a laptop is a bad match for a line-level or headphone-level signal.)