USB option not displayed in Recording Device: drop-down menu

Hello, I am using Audacity 2.x on windows Vista. I was converting my tapes with no problem having watched the YouTube video. However now, when I go to the dropdown menu in Recording Device:, it no longer displays the USB option, so I can no longer perform conversions. I have tried the following: a) checking the USB cable, which is working fine with other devices b) changing the batteries, which were dead c) updating to Audacity 2.1.0, but none of these solutions has worked. Can you help me please? I’ve attached a pic of the drop-down menu as it currently displays. Thanks, Mark :smiley:
USB not displayed.JPG

Audacity looks for available device when Audacity is launched. It does not look again unless you tell it to.
Generally it is best to connect the USB device before you launch Audacity, otherwise you will need to tell Audacity to rescan for audio devices (near the bottom of the Transport menu) after you connect the USB device.

Hi Steve, I’m afraid your suggestion to rescan has not worked, and the USB port option is still not displaying. Do I need to recharge the device or does the device run from batteries only? Thanks, Mark

You’ve not said what exactly the USB device is, but if it takes batteries then I’d guess that flat batteries could be the problem.

Hi Steve, I’m using the T2MP3 device. I’ve changed the batteries already as I said, but this hasn’t solved the problem. Any ideas? Mark

Look in the Windows Sound Control Panel to see if the device is recognised by windows as a recording device.

Windows Sounds.JPG
Thanks Steve - I had a look but it doesn’t look like the device is recognised by Windows (see pic). It was working perfectly well before, so I don’t know why it isn’t now. Any other ideas? Mark

You need to look in the “Recording” tab (your picture shows the “Playback” tab).
If the USB device is not recognised by Windows then you will not be able to record from it.

Things to check:
If possible, try a different USB lead.
Try a different USB socket on the computer.
Try rebooting.
If possible, try the T2MP3 on a different computer.

@wristy151966: You can take a picture of the whole screen using PrtScr and of a dialogue using ALT + PrtScr. Then open Paint, paste and save as a PNG image.

Tape2MP3 has an audio output so you could record from it that way. Most computers these days only have a mic input (mono or compatible for low quality stereo) but it may be acceptable if these are mono speech tapes.


Gale

Hi Steve/Gale, it looks like it isn’t recognised by my PC as a recording device (see pic). Since the USB lead works with other devices and in other PCs (I’ve already checked this), presumably that means that the socket in the T2MP3 device is no longer working? I don’t want to use the other audio option you refer Gale as the sound quality won’t be good enough. Mark
Windows recording devices.JPG
Windows Sounds.JPG

Is the USB cable attached tightly? If you have a different USB cable I recommend trying it.

Otherwise all you can do is try all the steps in the green panel “Detecting USB and Firewire devices” here: Audacity Manual.

When I suggested using the computer microphone input, I meant connecting a stereo to stereo cable between the external mic input and the T2MP3 audio output (in case that wasn’t clear).


Gale

Hi Gale, thanks for the suggestions, which I’ll try and get back to you. Yours, Mark

I’m having the same problem. I installed the software when I got this new cassette converter, and the instructions say to pick USB Audio device. That isn’t a choice, though. This is a new device with new cables and new batteries.

https://forum.audacityteam.org/t/usb-option-not-displayed-in-recording-device-drop-down-menu/39084/11

Koz

It’s six years after this post and I am having the exact same problem! (Using Audacity on Mac.) I recorded a big stack of cassettes successfully, but then Audacity stopped showing a USB option in the Recording Devices menu. I’ve tried all the troubleshooting suggestions but nothing works. Did anyone here ever figure out a solution?

dorian: Please do not double-post - locking this topic. See: https://forum.audacityteam.org/t/usb-option-vanished-from-dropdown-menu/61930/1