USB mixers on win 10

My setup is following
Yamaha AG-03
Yamaha Audiogram 3

Audio Technica AT2020
Steinberg ST-M01
AKG (dynamic)

Operatingsystem: Win 10

Recording software:
Audacity 3.1.3 Wasapi, ds, MME - no difference.

I have tried, with both mixers, on 3 win 10 computers, all drivers installed, and mixers recognized by audacity, but absolutely no sound coming in. I have used phantom on the mic.
I have tried all the twaks and permissions in windows, and still no sound.

What am I missing?

Have you tried Transport > Rescan Audio Devices ?

I do have the options to select either usb device or usb device (loopback) as input. Neither works.

(You can lead a horse to water…) :wink:

I’ve never had a problem with my AG03. This is with Audacity 2.4.2 (since they seem unable to release a 3.x version that doesn’t have any showstopper bugs, like punch and roll being broken in 3.1.2 and 3.1.3) on Windows 10 21H1 64-bit. Line and microphone inputs both work, stereo or mono; output work; zero problems to report. I use WASAPI but I believe the other input options worked when I tested them.