USB microphone buzz/distortion

I use Audacity (on OS X) with a Zoom H2 digital recorder, sometimes stand-alone but usually hooked up to the Mac and used as a microphone, enabling me to overdub existing tracks.

I’ve been recording fairly regularly for the last year without problems. But back in January I started getting some weird interference/distortion when I recorded using the H2 as a microphone. What happens is that it picks up what I’m playing but muffles and distorts it and adds a buzz, although the buzz only goes on as long as the sound input does. The waveform looks to be about the right dimensions, but it’s square-shaped. It’s as if the audio is being massively over-driven - so that every sound, however quiet, distorts and gets ‘clipped’ - and then magically adjusted back down to the right level. Needless to say, anything recorded this way is unusable.

I asked around when it started happening, but nobody I spoke to recognised the problem. Then it stopped happening, so I stopped worrying about it. Now it’s started again - and it’s happening, with monotonous regularity, every time I use the H2 as a USB microphone except the first time after I connect it. So every time I want to overdub a track (which I do a lot) I need to physically disconnect the H2, tell Audacity to re-scan (so that it knows the H2’s not there), reconnect, tell the H2 firmware to connect, and tell Audacity to re-scan again. It’s laborious, to say the least!

It happens with Audacity 2.0.1; it happens when the H2’s connected directly into the back of the Mac; it happens when there’s nothing else running. It doesn’t happen, ever, when I connect the H2 for the first time.

Any ideas?

I use an H2 (on Linux).
It’s not a problem that I recognise either.

Try using the H2 (a lot) in standalone mode and try to recreate the problem. It probably will not happen in standalone mode, but give it a really good workout to make sure that it doesn’t. If it does, then it could be the L/M/H mic gain switch or something related to that causing problems.

Another possibility is that something may be causing the system sound settings to change. Ensure that you don’t have Skype or any other voip application running in the background. I don’t know much about the Mac sound system so I’ll move this topic to the Mac OS X section of the forum.

It’s just a bit weird that what triggers it seems to be using the H2 over USB successfully. I get one go, and then it’s square waveforms and buzzing.

I’ve never had the problem using the H2 standalone. I don’t think it’s the gain switch - I toggle between M and H quite frequently, and it doesn’t have any effect on whether this error occurs.

Here’s an interesting bit of data: the microphone works fine if I use it to record audio using Quicktime, even when it’s producing nothing but buzz on Audacity. So it’s definitely an Audacity problem, not a Mac or H2 problem.

Does it only occur when you are making an overdub recording?

No. It only seems to happen after I’ve already been using Audacity, but I have tried starting a new project and recording the first track after it’s started; it still happens on the new track. On the other hand, when I tried this I did have a project with five or six tracks open in another window, so the fact that I wasn’t overdubbing doesn’t mean Audacity didn’t have a lot to cope with.

I’m also getting quite a few 0.05-second dropouts at the moment, which suggests something somewhere is being overloaded - although why it should have this effect is a mystery.

Are you running your H2 on the latest software level? Are you aware that latest software levels can be downloaded from ?

I’ve upgraded the H2 firmware.

Having done that, I tried quitting everything else, going into Audacity, connecting up the H2 and recording a single track, then overdubbing a second track.

The results are even worse! The first track I recorded is here (17 seconds). As you can hear, there’s a distinct electrical buzz accompanying the music throughout. I then recorded the same melody as an overdub: the result is here (caution: not pretty). This was recorded immediately after the first one, without changing anything.

Here’s the same thing, recorded into Quicktime and standalone. There is some electrical ‘ticking’ on the QT recording, which is interesting, although it’s not as bad as either of the Audacity recordings.

If I want to get anything recorded I’m clearly going to have to use the H2 stand-alone and just use Audacity to synch up multiple separate WAV files - unless and until the problem goes away, as it did once before. But what on earth is causing it?

Update: I rebooted the Mac and the problem, er, went away.

It takes a lot to make me reboot the Mac, but on this occasion it was definitely worth it. Of course, I still don’t know what was causing the problem, but at least now I know a way to fix it.